Bug 131439 - .pyc files have buildroot path in them
.pyc files have buildroot path in them
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On: 127243
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 10:22 EDT by Peter Jones
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 16:29:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Jones 2004-09-01 10:22:22 EDT
If I remove, for example, csv.py and csv.so, I get this in the call
trace when the compiled .pyc tries to load it csv.so:

File "<stdin>", line 1, in ?
File
"/usr/src/build/410155-x86_64/install/usr/lib64/python2.3/csv.py",
line 7, in ?

It shouldn't be a buildroot path there.
Comment 1 Mihai Ibanescu 2004-11-04 13:28:59 EST
Fixed in python 2.3.4-12 or newer.
Comment 2 John Thacker 2006-10-29 16:29:50 EST
Closing, since it should be fixed in all supported versions of Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.