Bug 1314409 - sigsegv after start
sigsegv after start
Status: CLOSED DUPLICATE of bug 1310496
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Catanzaro
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-03-03 09:10 EST by Jan Synacek
Modified: 2016-03-03 09:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-03-03 09:13:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
bt full (5.19 KB, text/plain)
2016-03-03 09:10 EST, Jan Synacek
no flags Details
bt full all threads (55.65 KB, text/plain)
2016-03-03 09:10 EST, Jan Synacek
no flags Details

  None (edit)
Description Jan Synacek 2016-03-03 09:10:00 EST
Created attachment 1132801 [details]
bt full

Description of problem:
Epiphany segfaults after start.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. $ epiphany
Segmentation fault (core dumped)

Additional info:
(gdb) bt
#0  0x00007ffff114ba90 in INT_cairo_region_is_empty (region=0x0) at cairo-region.c:816
#1  0x00007ffff1d281d6 in buffer_release_callback (_data=0x55555623b000, wl_buffer=<optimized out>) at gdkwindow-wayland.c:686
#2  0x00007fffe721bc58 in ffi_call_unix64 () at ../src/x86/unix64.S:76
#3  0x00007fffe721b6ba in ffi_call (cif=cif@entry=0x7fffffffdb50, fn=<optimized out>, rvalue=<optimized out>, 
    rvalue@entry=0x0, avalue=avalue@entry=0x7fffffffdc20) at ../src/x86/ffi64.c:525
#4  0x00007fffea177a9e in wl_closure_invoke (closure=closure@entry=0x55555625fdd0, flags=flags@entry=1, target=<optimized out>, 
    target@entry=0x555556271800, opcode=opcode@entry=0, data=<optimized out>) at src/connection.c:949
#5  0x00007fffea174840 in dispatch_event (display=display@entry=0x555555848220, queue=<optimized out>) at src/wayland-client.c:1274
#6  0x00007fffea175a14 in wl_display_dispatch_queue_pending (queue=0x5555558482e8, display=0x555555848220)
    at src/wayland-client.c:1420
#7  0x00007fffea175a14 in wl_display_dispatch_queue_pending (display=0x555555848220, queue=0x5555558482e8)
    at src/wayland-client.c:1662
#8  0x00007ffff1d207c4 in _gdk_wayland_display_queue_events (display=<optimized out>) at gdkeventsource.c:165
#9  0x00007ffff1cc2f9c in gdk_display_get_event (display=display@entry=0x55555584f010 [GdkWaylandDisplay]) at gdkdisplay.c:392
#10 0x00007ffff1d20542 in gdk_event_source_dispatch (base=base@entry=0x55555585fec0, callback=<optimized out>, data=<optimized out>) at gdkeventsource.c:86
#11 0x00007ffff0145ba3 in g_main_context_dispatch (context=0x555555847a50) at gmain.c:3154
#12 0x00007ffff0145ba3 in g_main_context_dispatch (context=context@entry=0x555555847a50) at gmain.c:3769
#13 0x00007ffff0145f50 in g_main_context_iterate (context=context@entry=0x555555847a50, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3840
#14 0x00007ffff0145ffc in g_main_context_iteration (context=context@entry=0x555555847a50, may_block=may_block@entry=1)
    at gmain.c:3901
#15 0x00007ffff07112ed in g_application_run (application=0x5555558be140 [EphyShell], argc=1, argv=0x7fffffffe078)
    at gapplication.c:2363
#16 0x0000555555586a84 in main (argc=<optimized out>, argv=<optimized out>) at ephy-main.c:479
Comment 1 Jan Synacek 2016-03-03 09:10 EST
Created attachment 1132802 [details]
bt full all threads
Comment 2 Michael Catanzaro 2016-03-03 09:13:52 EST

*** This bug has been marked as a duplicate of bug 1310496 ***

Note You need to log in before you can comment on or make changes to this bug.