Bug 1314422 - [GSS] - NRPE output is getting truncated after 1024 chars in RHEL 7
[GSS] - NRPE output is getting truncated after 1024 chars in RHEL 7
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons (Show other bugs)
3.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kanagaraj
RHS-C QE
: Reopened
: 1314419 (view as bug list)
Depends On: 1230194 1316177 1316180
Blocks: 1202842 1231420 1231422 1314419
  Show dependency treegraph
 
Reported: 2016-03-03 09:56 EST by Mukul Malhotra
Modified: 2016-06-21 06:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1230194
Environment:
Last Closed: 2016-03-09 08:37:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Mukul Malhotra 2016-03-03 10:08:55 EST
Hello,

One of the customer have the same issue as per BZ#1230194 in RHEL 7 where the NRPE output is getting truncated after 1024 characters. This happens with the following package for RHEL 7:

 nrpe-2.15-4.el7.x86_64

Thanks
Mukul
Comment 3 Sahina Bose 2016-03-03 10:42:12 EST
The package used is not from rhgs channel. The nrpe package in rhgs is patched to fix the 1024 payload size - 	nrpe-2.15-4.2.el7rhgs.x86_64.rpm

How's the RHEL 7 gluster node installed? What are the channels registered to?
Comment 5 Mukul Malhotra 2016-03-03 12:10:08 EST
*** Bug 1314419 has been marked as a duplicate of this bug. ***
Comment 6 Mukul Malhotra 2016-03-08 06:47:50 EST
Hello Sahina,

Does the issue also been fixed for NRPE package that belongs to RHEL 6 & 7 repository. for example, nrpe-2.15-4.el7.x86_64 or in next release of RHEL cycle  ?

Thanks
Mukul
Comment 7 Sahina Bose 2016-03-08 10:08:25 EST
(In reply to Mukul Malhotra from comment #6)
> Hello Sahina,
> 
> Does the issue also been fixed for NRPE package that belongs to RHEL 6 & 7
> repository. for example, nrpe-2.15-4.el7.x86_64 or in next release of RHEL
> cycle  ?
> 
> Thanks
> Mukul

nrpe-2.15-4.2.el7rhgs.x86_64.rpm - is the one in RHEL 7 repo. 
nrpe-2.15-4.2.el6rhs.x86_64.rpm - rhel 6
Comment 8 Mukul Malhotra 2016-03-09 08:37:49 EST
Hello,

Thanks for the assistance, but its actually for client (RHEL 6 & RHEL 7). I will open a RHEL bug.

Thanks
Mukul

Note You need to log in before you can comment on or make changes to this bug.