Bug 1314434 - UI: Advanced Search - Delete button remains enabled after deleting the filter
UI: Advanced Search - Delete button remains enabled after deleting the filter
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.6.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Kyrylo Zvyagintsev
: ZStream
Depends On: 1298645
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 10:22 EST by Chris Pelland
Modified: 2017-08-29 21:23 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298645
Environment:
Last Closed: 2016-04-13 14:45:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2016-03-15 18:01:14 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/06c215b9c0be6d40d2a0ad82f245bae5b7c6c4eb

commit 06c215b9c0be6d40d2a0ad82f245bae5b7c6c4eb
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Mar 3 09:53:14 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Mar 3 10:23:59 2016 -0500

    Clear selected filter after it is deleted or reset button is pressed.
    
    Not clearing the filter after filter is deleted is causing to show "Delete" as enabled after filter is deleted and pressing it again throws an error.
    This also removes empty parenthesis in the title on Advanced search modal when Delete/Reset is pressed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1298645
    https://bugzilla.redhat.com/show_bug.cgi?id=1314434

 app/controllers/application_controller/filter.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 3 CFME Bot 2016-03-16 12:47:08 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e20afea6815416161690843ba7b4b53d6fea3cff

commit e20afea6815416161690843ba7b4b53d6fea3cff
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Mar 3 09:53:14 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Mar 16 09:15:51 2016 -0400

    Clear selected filter after it is deleted or reset button is pressed.
    
    Not clearing the filter after filter is deleted is causing to show "Delete" as enabled after filter is deleted and pressing it again throws an error.
    This also removes empty parenthesis in the title on Advanced search modal when Delete/Reset is pressed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1298645
    https://bugzilla.redhat.com/show_bug.cgi?id=1314434
    (cherry picked from commit 06c215b)

 app/controllers/application_controller/filter.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 4 CFME Bot 2016-03-16 12:47:16 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cc8887037b1d3ac2a15acfe9d6217ff7c1fdb555

commit cc8887037b1d3ac2a15acfe9d6217ff7c1fdb555
Merge: 4e7fc09 e20afea
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Mar 16 12:23:46 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Mar 16 12:23:46 2016 -0400

    Merge branch '55z_pr_7083' into '5.5.z'
    
    Clear selected filter after it is deleted or reset button is pressed.
    
    Not clearing the filter after filter is deleted is causing to show "Delete" as enabled after filter is deleted and pressing it again throws an error.
    This also removes empty parenthesis in the title on Advanced search modal when Delete/Reset is pressed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1298645
    https://bugzilla.redhat.com/show_bug.cgi?id=1314434
    (cherry picked from commit 06c215b)
    
    @dclarizi please review, clean cherry-pick from https://github.com/ManageIQ/manageiq/pull/7083
    
    See merge request !855

 app/controllers/application_controller/filter.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 9 errata-xmlrpc 2016-04-13 14:45:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.