Bug 1314443 - Notification to inform the user about a pending password expiry
Notification to inform the user about a pending password expiry
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On: 1429631
Blocks: 1298243 1420851 1473733 1334464 1393395
  Show dependency treegraph
 
Reported: 2016-03-03 10:45 EST by Stefan Meyer
Modified: 2018-05-17 10:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.26.2-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1334464 (view as bug list)
Environment:
Last Closed: 2018-04-10 08:55:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 790066 None None None 2018-01-18 09:12 EST
FreeDesktop.org 70052 None None None 2016-07-28 07:04 EDT
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 08:57 EDT

  None (edit)
Description Stefan Meyer 2016-03-03 10:45:39 EST
Description of problem:
GDM shows a brief notification message that a users password will expire in X days.
The message is displayed underneath the password prompt when the graphical login is used.

This message scrolls through very fast and a user might miss the notifications until
the password finally expires and needs to get changed. 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server and Workstation, Release 7.x

Steps to Reproduce:
1. Create a new user
# useradd test

2. Set a password for the new user
# passwd test

3. Change the password expiration (5 days) and warning time (6 days)
# chage -M 5 -W 6 test

4. Login via graphical interface

Actual Results:
- login works
- a brief message appears below the password entry field that the password is going to expire in 5 days

Request for Enhancement:
- There shall be a notification for the user in either the Gnome notification area or a popup

When should it be shown:
- Depending on the configured "Number of days of warning before password expires" value,
  delivered by LDAP, local user configuration or Kerberos configuration
- After login
- After screen unlock
- It shall be shown again when it was not shown in the last X hours (e.g. no login, no screen unlock happened)
  This should be configurable by the system administrator.

How should it work:
- It should be visible (Notification area or Popup)
- It should not block further action (Popup)
- It should not stack (i.e. if the user leaves the notification open without confirming,
    it should not open a 2nd notification. But it shall make sure the 1st notification
    is visible again (on top, un-minimized). 
- It should go away when the user clicks "OK" (Popup)
- It should leave an icon in panel bar (even if user clicks OK)
- The Notification should show again if a user clicks on the icon in panel bar
Comment 7 Bastien Nocera 2016-05-10 06:46:17 EDT
This is similar to:
https://bugzilla.gnome.org/show_bug.cgi?id=708846

Filed upstream at:
https://bugzilla.gnome.org/show_bug.cgi?id=766219
Comment 9 Bastien Nocera 2016-07-28 07:04:23 EDT
Any progress is blocked on an AccountsService feature request:
https://bugs.freedesktop.org/show_bug.cgi?id=70052

You might want to file a bug for this RFE specifically if you want this to go forward.
Comment 12 Bastien Nocera 2017-03-06 12:47:09 EST
Filed as https://bugzilla.redhat.com/show_bug.cgi?id=1429631 as no movement happened upstream on the AccountsService bug.

Note that we'd still require non-trivial changes to gnome-settings-daemon to implement this functionality.
Comment 22 Michael Boisvert 2018-01-04 12:05:35 EST
I can verify the password expiration changes have been made successfully in 3.26. There is a brief notification when you log in that the password will expire in X days. After screen unlock, a panel notification is shown alerting the user that the password will expire soon. Once the password expires, you are forced to change the password at the log in screen.
Comment 27 errata-xmlrpc 2018-04-10 08:55:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.