Bug 1314450 - Failed to put host into maintenance while host is SPM
Failed to put host into maintenance while host is SPM
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.4
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.5
: ---
Assigned To: Allon Mureinik
Aharon Canan
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 11:08 EST by Meni Yakove
Modified: 2016-03-06 03:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-06 03:27:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
myakove: planning_ack?
myakove: devel_ack?
myakove: testing_ack?


Attachments (Terms of Use)
rhevm logs (302.08 KB, application/x-bzip)
2016-03-03 11:08 EST, Meni Yakove
no flags Details
vdsm logs (57.73 KB, application/x-bzip)
2016-03-03 11:10 EST, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2016-03-03 11:08:22 EST
Created attachment 1132856 [details]
rhevm logs

Description of problem:
Failed to put host into maintenance while host is SPM

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Put SPM host into maintenance

Actual results:
Failed

Expected results:
Succeed



2016-03-03 12:26:18,800 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (ajp-/127.0.0.1:8702-1) [hosts_syncAction_312ae900-077b-4176] SpmStopVDSComm
and::Not stopping SPM on vds 'host_mixed_1', pool id '37f6ae0b-9b57-4f55-bdc5-d8782e55ffc0' as there are uncleared tasks
2016-03-03 12:26:18,800 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStopVDSCommand] (ajp-/127.0.0.1:8702-1) [hosts_syncAction_312ae900-077b-4176] FINISH, SpmSto
pVDSCommand, log id: 2d13103e
2016-03-03 12:26:18,800 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.ResetIrsVDSCommand] (ajp-/127.0.0.1:8702-1) [hosts_syncAction_312ae900-077b-4176] FINISH, Reset
IrsVDSCommand, log id: 56e0eb39
2016-03-03 12:26:18,803 WARN  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-1) [hosts_syncAction_312ae900-077b-4176] Corre
lation ID: null, Call Stack: null, Custom Event ID: -1, Message: Failed to change status of host host_mixed_1 due to a failure to stop the spm.
Comment 1 Meni Yakove 2016-03-03 11:10:03 EST
rhevm-3.6.5-0.1000.1032.c40eb89.master.el6.noarch
vdsm-4.17.23-0.el7ev.noarch
Comment 2 Meni Yakove 2016-03-03 11:10 EST
Created attachment 1132857 [details]
vdsm logs
Comment 3 Allon Mureinik 2016-03-06 03:27:12 EST
The SPM has tasks on it, it should not be stopped. This is not a bug.

Note You need to log in before you can comment on or make changes to this bug.