Bug 1314451 - Untranslated label in anaconda
Untranslated label in anaconda
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Translation
Depends On:
Blocks: 1340415
  Show dependency treegraph
 
Reported: 2016-03-03 11:11 EST by Vit Ry
Modified: 2016-11-03 19:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.62-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:22:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot (73.95 KB, image/png)
2016-03-03 11:11 EST, Vit Ry
no flags Details

  None (edit)
Description Vit Ry 2016-03-03 11:11:22 EST
Created attachment 1132858 [details]
Screen shot

Description of problem:

There is untranslated string in anaconda, which doesn't change with UI-language changes.


Version-Release number of selected component (if applicable):

anaconda-21.48.22.56-1

How reproducible:
always

Steps to Reproduce:
1. Find some already installed system (VM)
2. Start anaconda
3. Choose non-english language
4. Go to "INSTALLATION DESTINATION" spoke
5. Press Done (it will be automatic partitioning radio) - "RECLAIM DISK SPACE" dialog appears
6. Press Reclaim space button

Actual results:

There is text: "Installation requires a total of ... for system data" in english, instead of non-english language (see screen shot).


Expected results:

Label is translated into target-language.


Additional info:

Looks like translation ( _(...)) for this string is missed in logic.

Here is src: https://github.com/rhinstaller/anaconda/blob/rhel7-branch/pyanaconda/ui/gui/spokes/lib/resize.glade#L313
Here it fills with data: https://github.com/rhinstaller/anaconda/blob/rhel7-branch/pyanaconda/ui/gui/spokes/lib/resize.py#L84
Comment 2 Vit Ry 2016-03-04 04:07:22 EST
Also there is untranslated text on "Help!" button.
Comment 3 David Shea 2016-03-04 11:42:52 EST
Adding l10n to cc since this would involve a new translation. The string is "Installation requires a total of <b>%s</b> for system data."

(In reply to Vit Ry from comment #2)
> Also there is untranslated text on "Help!" button.

There are translations available for this string, but anaconda is not using them correctly.
Comment 4 Noriko Mizumoto 2016-03-07 19:54:16 EST
(In reply to David Shea from comment #3)
> Adding l10n to cc since this would involve a new translation. The string is
> "Installation requires a total of <b>%s</b> for system data."
> 
> (In reply to Vit Ry from comment #2)
> > Also there is untranslated text on "Help!" button.
> 
> There are translations available for this string, but anaconda is not using
> them correctly.

I can see seven supported languages incomplete at rhel7-branch. If I organize the translation resource for update, can you pull them for rhel-7.3?
https://fedora.zanata.org/iteration/view/anaconda/rhel7-branch/languages/

Due to high localization demand for Korean and Italian, these two languages may not be delivered. Please advise if this may cause problem.

For the string "Installation requires a total of <b>%s</b> for system data.", as David mentioned, it has been localized already. And this is something translation team can not help.
Comment 11 David Shea 2016-03-31 10:38:45 EDT
Reassigning since this is now concerns the availability of translations for the "Installation requires a total of <b>%s</b> for system data." string.
Comment 12 Noriko Mizumoto 2016-04-03 08:56:28 EDT
This particular translation has already been translated into es and fr on zanata rhel-7 branch. Nothing to do for Localization team.
"Installation requires a total of <b>%s</b> for system data." 
https://fedora.zanata.org/iteration/view/anaconda/rhel7-branch/languages/

Besides, I can see that there are some update on rhel-7 branch, and can procure the translation resource when this branch is finalized. I am planning second translation cycle to be happened btw end of May to Mid Jun. In order to evaluate the workload, I need to know when final update will be added into the branch asap.
Please advise.
Comment 14 David Shea 2016-04-04 09:47:41 EDT
Updated fixed-in-version for the version when es and fr translations were available.
Comment 21 errata-xmlrpc 2016-11-03 19:22:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.