Bug 1314467 - /etc/init.d/ceph-radosgw reload fails
/etc/init.d/ceph-radosgw reload fails
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
1.2.3
All Linux
medium Severity low
: rc
: 1.3.2
Assigned To: Ali Maredia
ceph-qe-bugs
:
: 1320117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 11:58 EST by Sebastien Aime
Modified: 2017-07-30 11:53 EDT (History)
14 users (show)

See Also:
Fixed In Version: RHEL: ceph-0.94.5-12.el7cp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-06 14:39:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2189411 None None None 2016-03-29 01:48 EDT

  None (edit)
Description Sebastien Aime 2016-03-03 11:58:15 EST
Hello,

Issuing /etc/init.d/ceph-radosgw reload fails. We have successfully tested the following patch:

if [ $DEBIAN -eq 1 ]; then
             start-stop-daemon --stop --signal HUP -x $RADOSGW --oknodo
 	else
-            killproc $RADOSGW -SIGHUP
+            killproc $RADOSGW -HUP
 	fi
 	;;
     restart|force-reload)

https://github.com/herver/ceph/commit/1b000abac3a02d1e788bf25eead4b6873133f5d2

Best regards,

Sebastien.
Comment 1 Boris Ranto 2016-03-05 09:30:27 EST
We do not ship rgw in RHEL, the radosgw package is part of the RHCEPH product -> re-targetting.
Comment 3 Boris Ranto 2016-03-05 09:32:05 EST
Also, we should target this at 1.3.z, ceph 2 will use systemd unit files.
Comment 6 Vikhyat Umrao 2016-04-13 11:20:48 EDT
*** Bug 1320117 has been marked as a duplicate of this bug. ***
Comment 14 shylesh 2016-04-27 05:22:24 EDT
Verified on 
ceph-osd-0.94.5-12.el7cp.x86_64
ceph-common-0.94.5-12.el7cp.x86_64
ceph-selinux-0.94.5-12.el7cp.x86_64
ceph-radosgw-0.94.5-12.el7cp.x86_64
mod_fastcgi-2.4.7-1.ceph.el7.x86_64
iozone-3.424-2_ceph.el7.x86_64
ceph-0.94.5-12.el7cp.x86_64




[ubuntu@magna116 ~]$ sudo  /etc/init.d/ceph-radosgw reload
Reloading ceph-radosgw configuration (via systemctl):      [  OK  ]
[ubuntu@magna116 ~]$ ps aux | grep rados
root      6619  0.1  0.0 7411772 25240 ?       Ssl  05:25   0:17 /bin/radosgw -n client.rgw.magna116
ubuntu   24246  0.0  0.0 112648   960 pts/0    S+   09:15   0:00 grep --color=auto rados
[ubuntu@magna116 ~]$ sudo  /etc/init.d/ceph-radosgw restart
Restarting ceph-radosgw (via systemctl):                   [  OK  ]
[ubuntu@magna116 ~]$ ps aux | grep rados
root     24367  1.0  0.0 7410744 13856 ?       Ssl  09:16   0:00 /bin/radosgw -n client.rgw.magna116
ubuntu   24515  0.0  0.0 112644   960 pts/0    S+   09:16   0:00 grep --color=auto rados
[ubuntu@magna116 ~]$ sudo  /etc/init.d/ceph-radosgw stop
Stopping ceph-radosgw (via systemctl):                     [  OK  ]
[ubuntu@magna116 ~]$ sudo  /etc/init.d/ceph-radosgw start
Starting ceph-radosgw (via systemctl):                     [  OK  ]
[ubuntu@magna116 ~]$ ps aux | grep rados
root     24710  1.7  0.0 7410704 19992 ?       Ssl  09:16   0:00 /bin/radosgw -n client.rgw.magna116
ubuntu   24858  0.0  0.0 112644   960 pts/0    S+   09:17   0:00 grep --color=auto rados
[ubuntu@magna116 ~]$ sudo  /etc/init.d/ceph-radosgw status
/bin/radosgw is running.
Comment 16 errata-xmlrpc 2016-05-06 14:39:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0721.html

Note You need to log in before you can comment on or make changes to this bug.