Bug 1314504 - host name parameter is missing in JON when we miss it in host.xml
host name parameter is missing in JON when we miss it in host.xml
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7 (Show other bugs)
JON 3.3.5
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michael Burman
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 14:05 EST by Jeeva Kandasamy
Modified: 2016-03-04 05:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 05:50:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host name parameter screenshot (116.20 KB, image/png)
2016-03-03 14:05 EST, Jeeva Kandasamy
no flags Details
host name parameter screenshot - updated (104.54 KB, image/png)
2016-03-04 05:50 EST, Jeeva Kandasamy
no flags Details

  None (edit)
Description Jeeva Kandasamy 2016-03-03 14:05:04 EST
Created attachment 1132899 [details]
host name parameter screenshot

Description of problem:
host name parameter is empty when we removed the name parameter from host.xml.

Version-Release number of selected component (if applicable):
JBoss ON 3.3.5 with EAP plugin pack update03-DR01


How reproducible:
always

Steps to Reproduce:
1. Unset host controller name parameter in host.xml
2. Register host controller in to JON

Actual results:
showing name parameter as empty

Expected results:
Should show the default hostname as a host name parameter.

Additional info:
JBoss CLI shows host name as host name parameter.

[domain@localhost:9990 /] /host=jeeva-dr01-fey.bc.jonqe.lab.eng.bos.redhat.com:read-attribute(name=name)      
{
    "outcome" => "success",
    "result" => "jeeva-dr01-fey.bc.jonqe.lab.eng.bos.redhat.com"
}

Screenshot is attached
Comment 1 Michael Burman 2016-03-04 04:21:56 EST
I don't think this is missing, but you were too quick to test. It takes a while for those values to be propagated. Took some minutes on my machine for them to appear (and same behavior on EAP6). Notice how in your screenshot none of the traits are visible (not just the domain name).

You can check if the values are correctly read by checking the traits, it's the same values just repeated on the UI.
Comment 3 Jeeva Kandasamy 2016-03-04 05:50 EST
Created attachment 1133141 [details]
host name parameter screenshot - updated

I was waiting couple of minutes. name parameter and other parameters are updated as expected. As this is known limitation and not a bug. Hence moving this bug to closed state.

Note You need to log in before you can comment on or make changes to this bug.