Bug 1314519 - Specify string column limits
Specify string column limits
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: David Davis
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 15:00 EST by Partha Aji
Modified: 2016-07-27 05:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14025 None None None 2016-04-22 12:50 EDT

  None (edit)
Description Partha Aji 2016-03-03 15:00:30 EST
In Rails 4.2 the default limit for PostgreSQL and SQLite adapters
changes to unlimited from 255 characters.  MySQL remains at 255 chars.
Existing migrations should be changed to specify the length, e.g.

  t.column :name, :string, :null => false, :limit => 255

This will ensure that the schema generated on a new installation exactly
matches the schema from an old installation, so there won't be varying
versions of the schema in the wild.
Comment 1 Partha Aji 2016-03-03 15:00:32 EST
Created from redmine issue http://projects.theforeman.org/issues/14025
Comment 2 Partha Aji 2016-03-03 15:00:35 EST
Upstream bug assigned to daviddavis@redhat.com
Comment 4 Bryan Kearney 2016-03-03 16:11:30 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/14025 has been closed
-------------
David Davis
Applied in changeset commit:katello|924700524dd6990d447030dcfb92caed0c28c3f2.
Comment 6 Kedar Bidarkar 2016-05-25 11:58:07 EDT
Please provide verification steps to test this.
Comment 7 David Davis 2016-05-28 17:39:48 EDT
Try entering a value longer than 255 chars for one of these fields:

https://github.com/Katello/katello/pull/5837/files

It must be a new install. A few example fields include activation key name, content view name, lifecycle environment name, etc
Comment 8 jcallaha 2016-06-16 10:13:51 EDT
Verified in Satellite 6.2 beta Snap 15.2

Forms accepting string input are correctly performing string length validation.
Comment 10 errata-xmlrpc 2016-07-27 05:25:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.