Bug 131454 - rawhide-20040901 xorg-x11 freezes system console during start
Summary: rawhide-20040901 xorg-x11 freezes system console during start
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 131451
TreeView+ depends on / blocked
 
Reported: 2004-09-01 16:11 UTC by Daniel Reed
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 19:46:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (49.32 KB, text/plain)
2004-09-01 18:36 UTC, Brian Millett
no flags Details

Description Daniel Reed 2004-09-01 16:11:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040704 Firefox/0.9.1

Description of problem:
After upgrading to today's rawhide, xorg-x11 is unable of starting.
When starting in runlevel 5, the system screen clears completely when
X attempts to start, the harddisk is accessed for about 10-15 seconds,
then harddisk activity stops and the machine becomes unresponsive.

I have allowed it to sit for minutes with no change. Ctrl-Alt-Del does
not cause activity. The only solution I have found is to power cycle.

If I boot into runlevel 3, login to my user account, and run startx,
the screen clears and leaves me in the same state as if I had booted
into runlevel 5.

This may be related to modules not being loaded from #131452. I can
provide any log files that might be helpful.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to rawhide-20040901
2. Reboot

Additional info:

Comment 1 Mike A. Harris 2004-09-01 17:19:41 UTC
Not enough information present in bug report.  Please supply more
details, X server log and config file, kernel log file all as
individual file attachments using bugzilla file attach feature.

What hardware are you using, and what driver?

Comment 2 Brian Millett 2004-09-01 18:36:25 UTC
Created attachment 103356 [details]
Xorg log

Comment 3 Brian Millett 2004-09-01 18:38:32 UTC
Just updated the rawhide.  Looks like the /dev/input/mice is not being
setup.
 
From /var/log/messages:
Sep  1 11:50:30 indoffcallacctg gpm[2765]: *** info [startup.c(95)]:
Sep  1 11:50:30 indoffcallacctg gpm[2765]: Started gpm successfully.
Entered daemon mode.
Sep  1 11:50:30 indoffcallacctg gpm[2765]: O0o.oops():
[server_tools.c(76)]:
Sep  1 11:50:30 indoffcallacctg gpm[2765]: Could not open /dev/input/mice.
Sep  1 11:50:30 indoffcallacctg gpm: O0o.oops(): [server_tools.c(76)]:
Sep  1 11:50:30 indoffcallacctg gpm: Could not open /dev/input/mice.
Sep  1 11:50:30 indoffcallacctg gpm: gpm startup succeeded

So from the Xorg.0.log:
(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
	No such file or directory.
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"
(II) UnloadModule: "mouse"
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(WW) No core pointer registered
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
No core pointer

Fatal server error:
failed to initialize core devices

Please consult the The X.Org Foundation support 
	 at http://wiki.X.Org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional
information.


   *** If unresolved symbols were reported above, they might not
   *** be the reason for the server aborting.

FatalError re-entered, aborting
Caught signal 4.  Server aborting



Comment 4 Mike A. Harris 2004-09-01 19:14:03 UTC
I don't think the information in the last 2 comments is related
to the original bug report.  I'll await djr's response to my
query before any conclusions though.

Comment 5 Mike A. Harris 2004-09-01 19:16:02 UTC
In reply to comment #3:  The X server just tries to open the
device it is told to open, so what you're seeing there is not
an X bug.  You're seeing the X server unable to open the device
it was told to open, because the device doesn't exist.  That is
either a misconfiguration, or a kernel bug, and if misconfiguration
can be ruled out, a kernel bug report should be filed I suppose.

Comment 6 Daniel Reed 2004-09-01 19:31:15 UTC
I upgraded udev, initscripts, and module-boot-tools (to fix other
problems) and am no longer able to reproduce the problem.

I can downgrade these components if you think it is worth tracking
down why the machine was dying in X rather than giving an error;
otherwise I guess it is okay to close this NOTABUG.

Thanks.

Comment 7 Mike A. Harris 2004-09-01 19:46:02 UTC
Ok, thanks for the update.  Assuming it was a non-X bug, that was
fixed with other system updates.

Closing "NOTABUG"


Note You need to log in before you can comment on or make changes to this bug.