Bug 1314541 - Atomic CLI - atomic info command is broken
Atomic CLI - atomic info command is broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lokesh Mandvekar
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 16:11 EST by Dusty Mabe
Modified: 2016-06-23 12:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 12:21:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dusty Mabe 2016-03-03 16:11:43 EST
Description of problem:

atomic info command is broken


Version-Release number of selected component (if applicable):
[root@rhel-cdk ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)
[root@rhel-cdk ~]# rpm -q atomic docker python-docker-py
atomic-1.8-6.git1bc3814.el7.x86_64
docker-1.8.2-10.el7.x86_64
python-docker-py-1.6.0-1.el7.noarch

How reproducible:
Always

Steps to Reproduce:

[root@rhel-cdk ~]# sudo atomic info registry.access.redhat.com/rhel7:latest
Could not find any image matching "registry.access.redhat.com/rhel7:latest".
[root@rhel-cdk ~]# docker images | grep rhel7
registry.access.redhat.com/rhel7                            latest              bf63a676257a        2 days ago          203.2 MB
Comment 3 Dusty Mabe 2016-03-08 13:52:07 EST
Someone has hinted to me that there may be compatibility issues with docker-py > 1.4 and docker < 1.9 that may be causing this bug. Asking for info from the interested party.
Comment 4 Brent Baude 2016-03-08 14:37:24 EST
Hey Dusty,

This has been fixed upstream with https://github.com/projectatomic/atomic/commit/ff44c6a9496d3b2ba8189170e30ae2e93fee9eb4 .  

The problem in the current packages is as follows:

< docker-1.8 is incompatible with python-docker-py > 1.4 as this will throw a docker/docker-client API error which was being masked by a generic docker error.

If you use docker-py-1.4 with docker-1.8 and atomic-1.8, the API error disappears but reveals an import error for a new error class in docker-py called NotFound (within verify.py) This compatibility issue was supposed to be handled via rpm deps but was missed.

So, if you choose to use docker-1.8, python-docker-py-1.6+, and atomic upstream master, everything will work.
Comment 5 Brent Baude 2016-03-08 14:58:19 EST
In the above comment, I mean so say, docker-1.9+, python-docker-py-1.6+ and atomic upstream.
Comment 6 Daniel Walsh 2016-06-03 16:00:07 EDT
Fixed in atomic-1.10
Comment 8 Alex Jia 2016-06-12 05:20:55 EDT
I gave a try on RHEL7 system w/ atomic-1.10.5-3.el7.x86_64, docker-1.10.3-40.el7.x86_64 and python-docker-py-1.7.2-1.el7.noarch, atomic info works well.

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.2 (Maipo)

# atomic info registry.access.redhat.com/rhel7:latest
Image Name: registry.access.redhat.com/rhel7:latest
Vendor: Red Hat, Inc.
Name: rhel7/rhel
Build_Host: rcm-img03.build.eng.bos.redhat.com
Version: 7.2
Architecture: x86_64
Release: 61
BZComponent: rhel-server-docker
Authoritative_Registry: registry.access.redhat.com


But atomic info doesn't work on RHAH 7.2.5, need I file a new bug? or waiting for new rhel-atomic-cloud building.

[cloud-user@atomic-host-001 ~]$ sudo atomic info registry.access.redhat.com/rhel7:latest
Image Name: registry.access.redhat.com/rhel7:latest
time="2016-06-12T09:11:04Z" level=fatal msg="error pinging repository, response code 404" 

[cloud-user@atomic-host-001 ~]$ cat /etc/redhat-release
Red Hat Enterprise Linux Atomic Host release 7.2

[cloud-user@atomic-host-001 ~]$ sudo atomic host status
  TIMESTAMP (UTC)         VERSION     ID             OSNAME               REFSPEC                                                   
* 2016-06-06 18:12:07     7.2.5       4bf265cf86     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
  2016-05-06 05:57:30     7.2.4       b060975ce3     rhel-atomic-host     rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
[cloud-user@atomic-host-001 ~]$ rpm -q atomic docker python-docker-py
atomic-1.10.3-1.el7.x86_64
docker-1.10.3-31.el7.x86_64
python-docker-py-1.7.2-1.el7.noarch

NOTE: docker search can find rhel7 in registry.access.redhat.com repo.
Comment 9 Daniel Walsh 2016-06-12 06:47:24 EDT
Does atomic info other non RHEL distributions work?  I think the problem might be the lack of support for V2 registries on the Red Hat site.
Comment 12 Alex Jia 2016-06-14 23:33:38 EDT
atomic info works well on RHEL7 system, so move the bug to verified status.
Comment 15 errata-xmlrpc 2016-06-23 12:21:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1273

Note You need to log in before you can comment on or make changes to this bug.