Bug 1314549 - remove replace-brick-self-heal.t from bad tests
remove replace-brick-self-heal.t from bad tests
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anuradha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 16:38 EST by Anuradha
Modified: 2016-09-19 22:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:59:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anuradha 2016-03-03 16:38:24 EST
Description of problem:
Ran the test in a loop for 1 hour, couldn't recreate the failure. Removing the testcase from bad tests.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-03 16:40:26 EST
REVIEW: http://review.gluster.org/13599 (Remove replace-brick-self-heal.t from bad-tests) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 2 Vijay Bellur 2016-03-04 07:44:41 EST
COMMIT: http://review.gluster.org/13599 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e6a29ab2947eba3ee12ba3a94d4f04c41a22b5a4
Author: Anuradha Talur <atalur@redhat.com>
Date:   Fri Mar 4 01:41:09 2016 +0530

    Remove replace-brick-self-heal.t from bad-tests
    
    Unable to recreate any failures even after running
    the test for more than an hour in a loop.
    
    Change-Id: Id1c7e60d39bce6b312dbb4ea0975079348bb1649
    BUG: 1314549
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13599
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:17:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:59:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.