Bug 1314562 - pyanaconda.nm.UnknownMethodGetError: UnknownMethodGetError()
pyanaconda.nm.UnknownMethodGetError: UnknownMethodGetError()
Status: CLOSED DUPLICATE of bug 1314560
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:ad8d5a4b4ba4d88182cf6dd70f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 17:57 EST by Filip Frackiewicz
Modified: 2016-03-04 09:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 09:26:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (522.04 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: anaconda.log (22.75 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: environ (616 bytes, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: journalctl (238.87 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: lsblk_output (2.83 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: nmcli_dev_list (1.54 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: os_info (451 bytes, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: program.log (50.87 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: storage.log (128.90 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details
File: ifcfg.log (2.58 KB, text/plain)
2016-03-03 17:57 EST, Filip Frackiewicz
no flags Details

  None (edit)
Description Filip Frackiewicz 2016-03-03 17:57:32 EST
Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/nm.py", line 128, in _get_property
    raise UnknownMethodGetError
  File "/usr/lib64/python3.4/site-packages/pyanaconda/nm.py", line 215, in nm_activated_devices
    iface = _get_property(device, "IpInterface", ".Device")
  File "/usr/lib64/python3.4/site-packages/pyanaconda/network.py", line 1383, in status_message
    active_devs = nm.nm_activated_devices()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1491, in status
    return network.status_message()
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 216, in _updateCompleteness
    spoke.selector.set_property("status", spoke.status)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 407, in spoke_done
    self._updateCompleteness(sp, update_continue=False)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 76, in on_back_clicked
    self.main_window.current_action.spoke_done(self)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1680, in on_back_clicked
    NormalSpoke.on_back_clicked(self, button)
pyanaconda.nm.UnknownMethodGetError: UnknownMethodGetError()

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Cinnamon-x86_64-23-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: anaconda-gui-23.19.10-1.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Filip Frackiewicz 2016-03-03 17:57:39 EST
Created attachment 1132942 [details]
File: anaconda-tb
Comment 2 Filip Frackiewicz 2016-03-03 17:57:41 EST
Created attachment 1132943 [details]
File: anaconda.log
Comment 3 Filip Frackiewicz 2016-03-03 17:57:42 EST
Created attachment 1132944 [details]
File: environ
Comment 4 Filip Frackiewicz 2016-03-03 17:57:45 EST
Created attachment 1132945 [details]
File: journalctl
Comment 5 Filip Frackiewicz 2016-03-03 17:57:47 EST
Created attachment 1132946 [details]
File: lsblk_output
Comment 6 Filip Frackiewicz 2016-03-03 17:57:48 EST
Created attachment 1132947 [details]
File: nmcli_dev_list
Comment 7 Filip Frackiewicz 2016-03-03 17:57:49 EST
Created attachment 1132948 [details]
File: os_info
Comment 8 Filip Frackiewicz 2016-03-03 17:57:52 EST
Created attachment 1132949 [details]
File: program.log
Comment 9 Filip Frackiewicz 2016-03-03 17:57:54 EST
Created attachment 1132950 [details]
File: storage.log
Comment 10 Filip Frackiewicz 2016-03-03 17:57:56 EST
Created attachment 1132951 [details]
File: ifcfg.log
Comment 11 David Shea 2016-03-04 09:26:27 EST

*** This bug has been marked as a duplicate of bug 1314560 ***

Note You need to log in before you can comment on or make changes to this bug.