Bug 1314563 - katello:reindex is not currently reindexing docker content
katello:reindex is not currently reindexing docker content
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Brad Buckingham
Jitendra Yejare
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 17:57 EST by Brad Buckingham
Modified: 2016-07-27 05:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14049 None None None 2016-04-22 11:08 EDT

  None (edit)
Description Brad Buckingham 2016-03-03 17:57:51 EST
Description of problem:

The 'foreman-rake katello:reindex' is often use to ensure that the Satellite (katello) database is kept in sync with backend services (e.g. pulp, candlepin).  While this is not something that is used all of the time, there are times that it is run as part of debugging and resolving issues.

It appears that the current re-index does not include Docker content (i.e. Katello::DockerManifest & Katello::DockerTag).  We should update this to be consistent.

Version-Release number of selected component (if applicable):
Satellite 6.2 snap 2

How reproducible:
always

Steps to Reproduce:

first, let's destroy the docker content in the katello database, leaving in place the data from backend services.  (Note: this should NOT be done on a production system, this is just for testing purposes)
1. foreman-rake console
2. User.current=User.first
3. Katello::DockerManifest.all.count   # keep the count
4. Katello::DockerTag.all.count        # keep the count

5. Katello::DockerManifest.destroy_all

6. Katello::DockerManifest.all.count   # should return 0
7. Katello::DockerTag.all.count        # should return 0

from outside of the console:
8. foreman-rake katello:reindex

from inside of the console:
9. Katello::DockerManifest.all.count   # should return same number as 3 above
10. Katello::DockerTag.all.count       # should return same number as 4 above

Actual results:

The counts from 3 & 9 and 4 & 10 do not match.

Expected results:

The counts should be the same, indicating that the docker content was re-indexed.  In addition, if look closer at the responses (without the '.count') the records should be similar (i.e. ids may be different, but the core content is the same).

Additional info:
Comment 1 Brad Buckingham 2016-03-03 17:58:14 EST
Created redmine issue http://projects.theforeman.org/issues/14049 from this bug
Comment 2 Bryan Kearney 2016-03-03 18:02:07 EST
Upstream bug component is Content Management
Comment 4 Brad Buckingham 2016-03-04 09:14:48 EST
Upstream Katello PR: https://github.com/Katello/katello/pull/5844
Comment 6 Jitendra Yejare 2016-04-15 05:03:20 EDT
Verified in Sat 6.2 snap 8.1.

The issue in not reproducible.

I see that, the counts of docker manifests and tags are same as earlier on re-indexing.


So moving this to verified.
Comment 8 errata-xmlrpc 2016-07-27 05:25:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.