This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314566 - [RFE] Ability to attach labels and annotations to ProjectsRequests
[RFE] Ability to attach labels and annotations to ProjectsRequests
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michal Fojtik
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-03 18:10 EST by Ryan Howe
Modified: 2017-09-05 09:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 09:51:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2016-03-03 18:10:14 EST
Description of problem:

When creating a project through the api users want the ability add labels and annotations with this request. 

  POST /oapi/v1/projectrequests


Right now to add labels or annotations to a project the name-space object must be modified or created with these values. 

Additional info:

https://docs.openshift.com/enterprise/3.1/rest_api/openshift_v1.html#v1-projectrequest
Comment 1 Paul Weil 2016-05-06 09:46:21 EDT
Right now the assumption is that labels and annotations are created by a highly privileged user. It is not clear what the use case is on this.  Can you give us some examples of what you'd use the labels and annotations for?
Comment 2 Ryan Howe 2016-08-19 16:45:38 EDT
Adding this to Projectrequests is not needed since labels and annotations are meant for priv users. 

Instead this request is so that one can set labels or annotations to a project with out needing to modify the namespace object.

https://docs.openshift.com/enterprise/3.1/rest_api/openshift_v1.html#create-a-project


The want for this is cut out extra api calls when creating a project.

Note You need to log in before you can comment on or make changes to this bug.