Bug 1314580 - [RFE] RGW: support swift bulk delete
[RFE] RGW: support swift bulk delete
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Yehuda Sadeh
shilpa
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2016-03-03 19:32 EST by Yehuda Sadeh
Modified: 2017-07-30 11:54 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
.Support for Swift `bulk-delete` has been added Red Hat Ceph Storage now supports the Swift `bulk-delete` feature. With this new feature, users can delete multiple objects from an account with a single request. For details see the https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/single/configuration-reference/#object-storage-bulk-delete[Bulk delete] section in the https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/single/configuration-reference[Configuration Reference] guide for Red Hat OpenStack Platform 8.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 19:23:52 EDT

  None (edit)
Description Yehuda Sadeh 2016-03-03 19:32:50 EST
To support the swift bulk delete api. This is needed for full swift SLO support.
Comment 2 Ken Dreyer (Red Hat) 2016-03-15 09:10:37 EDT
I take Yehuda's comment above to mean that this bug relates to the Swift SLO RFE in bug 1283407
Comment 10 shilpa 2016-08-02 04:54:39 EDT
Hi Bara,

Please add a link to openstack doc that explains how to perform a bulk delete.
Comment 14 shilpa 2016-08-08 06:17:10 EDT
Thanks Bara. Moving to verified.
Comment 16 errata-xmlrpc 2016-08-23 15:33:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.