Bug 1314619 - [RFE] Allow labels to be added to the pod during template instantiation from webconsole [NEEDINFO]
[RFE] Allow labels to be added to the pod during template instantiation from...
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Ben Parees
yapei
:
: 1375146 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 00:39 EST by Jaspreet Kaur
Modified: 2018-03-12 09:54 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-12 09:54:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
erich: needinfo? (jkaur)


Attachments (Terms of Use)

  None (edit)
Description Jaspreet Kaur 2016-03-04 00:39:47 EST
1. Proposed title of this feature request  
   Allow labels to be added to the pod during template instantiation from webconsole
    

3. What is the nature and description of the request?  
At present, It is not possible to specify additional labels that will end up on the resulting pods. Hence, the request is to create an arbitrary number of new labels that will be applied to the pod, during template instantiation.

      
4. Why does the customer need this? (List the business requirements here)  

For more user/developer friendly as it is a manual task to apply labels on a node it is tedious task. They would like to reuse this initial labeling in the node scheduler but because the pod is not labeled they can't use the node scheduler to determine where on what node the new pods should land.
      
5. How would the customer like to achieve this? (List the functional requirements here)

The labels that are applied from webconsole should be added to the pods.

      
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

Suppose a label kind-dev is added from the webconsole, the pod should have this like as below :

 oc get pod -l kind=dev
NAME                     READY     STATUS    RESTARTS   AGE
dancer-example-5-sc28w   1/1       Running   0          14h

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

The discussion came from : https://bugzilla.redhat.com/show_bug.cgi?id=1311945

8. Does the customer have any specific timeline dependencies and which release would they like to target?

ASAP   
      
9. Is the sales team involved in this request and do they have any additional input? 

no
      
10. List any affected packages or components.  
      
11. Would the customer be able to assist in testing this functionality if implemented?  
yes
Comment 2 Steve Speicher 2016-08-19 10:22:00 EDT
One option would be to update the template such that the labels are parameterized for the pod template and inserted there.

This requested behavior, if changed for everyone in web console, could have an unexpected impact to pod behavior. If we did it, we would probably make it an checkbox or some option to indicate that the pod templates should be updated. Though we'd need to still do a little more investigation on other impacts.
Comment 3 Ben Parees 2016-09-22 11:39:21 EDT
see also: 
https://bugzilla.redhat.com/show_bug.cgi?id=1375146
Comment 4 Ben Parees 2016-09-22 11:39:45 EDT
*** Bug 1375146 has been marked as a duplicate of this bug. ***
Comment 6 Eric Rich 2018-03-12 09:54:36 EDT
This bug has been identified as a dated (created more than 3 months ago) bug. 
This bug has been triaged (has a trello card linked to it), or reviewed by Engineering/PM and has been put into the product backlog, 
however this bug has not been slated for a currently planned release (3.9, 3.10 or 3.11), which cover our releases for the rest of the calendar year. 

As a result of this bugs age, state on the current roadmap and PM Score (being below 70), this bug is being Closed - Differed, 
as it is currently not part of the products immediate priorities.

Please see: https://docs.google.com/document/d/1zdqF4rB3ea8GmVIZ7qWCVYUaQ7-EexUrQEF0MTwdDkw/edit for more details.

Note You need to log in before you can comment on or make changes to this bug.