Bug 1314624 - [RFE]Redistribute pods between nodes
[RFE]Redistribute pods between nodes
Status: CLOSED DUPLICATE of bug 1319700
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 00:59 EST by Jaspreet Kaur
Modified: 2016-04-13 15:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 15:51:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2212441 None None None 2016-03-31 00:44 EDT

  None (edit)
Description Jaspreet Kaur 2016-03-04 00:59:41 EST
1. Proposed title of this feature request  
Redistribute PODS between nodes

3. What is the nature and description of the request?  
PODs are assigned to nodes at creation. Especially in our TEST and INTEGRATION environments, the number of pods is highly volatile. This leads to nodes that have more load than others. We would like a mechanism to redistribute the load of PODS when the distribution becomes unbalanced.
  
4. Why does the customer need this? (List the business requirements here)  
To make sure the end-users do not experience slow performance because all work is concentrated on a limited number of nodes when there is still capacity available on others.
  
5. How would the customer like to achieve this? (List the functional requirements here)  
* definition per project whether redistribution should be allowed or not (in production you may not want this to happen for non HA pods) and when/at which interval this should occur (f.e. only at night or in the weekend)
* if active, evaluate the load of the nodes and try to move pods from the nodes that are above the average load
* try to find a new spot before moving the pod (only move it when the system has a suitable node that has a lower load than the one from which you are moving)
  
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
* use a mix of projects with redistribution enabled and disabled. Only the ones with the feature enabled should have pods moved (and only at the specified time)
* start a lot of pods
* remove pods from a single node so the system becomes inbalanced
* make sure after the algorithm is applied that the system is balanced again
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

What information can you provide around timeframes and urgency?

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
OSE 3.3
    
10. List any affected packages or components.  
  
11. Would the customer be able to assist in testing this functionality if implemented? 
Yes.
Comment 2 Dan McPherson 2016-04-13 15:51:22 EDT

*** This bug has been marked as a duplicate of bug 1319700 ***

Note You need to log in before you can comment on or make changes to this bug.