Bug 1314633 - man-db rpm script failed when installed with glibc-minimal-langpack
man-db rpm script failed when installed with glibc-minimal-langpack
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 01:13 EST by Yu Watanabe
Modified: 2016-03-26 14:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: man-db-2.7.5-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:07:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install log of man-db with glibc-minimal-langpack (17.19 KB, text/plain)
2016-03-04 01:53 EST, Yu Watanabe
no flags Details

  None (edit)
Description Yu Watanabe 2016-03-04 01:13:08 EST
Description of problem:

When install man-db with glibc-minimal-langpack, the rpm script (I guess it is %transfiletriggerin script) after the installation fail.

The installation command I use is below.

dnf --disablerepo=* --enablerepo=rawhide \
    --installroot=/nfsroot/hoge -y install man-db glibc-minimal-langpack

The above command outputs the following error message (The full output is attached).
%%%%%%%%%%%%%%%%%%%%%%
(...)
  Installing  : man-db-2.7.5-2.fc24.x86_64                                50/50 
/usr/sbin/convert-to-edition: line 163: grub2-mkconfig: command not found
This system has been converted to non-edition
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct
  Verifying   : man-db-2.7.5-2.fc24.x86_64                                 1/50 
(...)
%%%%%%%%%%%%%%%%%%%%%%

Note that the first error message is comes from fedora-release package's bug.
If I install man-db with glibc-all-langpacks, the above error message is not shown.

Version-Release number of selected component (if applicable):

man-db-2.7.5-2.fc24.x86_64

How reproducible:

always

Steps to Reproduce:
1. install packages by using the above command.
2.
3.

Actual results:

Install finishes without error message.

Expected results:

Installation process shows the above error message.

Additional info:
Comment 1 Yu Watanabe 2016-03-04 01:53 EST
Created attachment 1133045 [details]
install log of man-db with glibc-minimal-langpack
Comment 2 Nikola Forró 2016-03-11 10:34:28 EST
Hello Yu,

the message is actually just warning, not error. It doesn't affect anything and the %transfiletriggerin scriptlet finishes successfully.
It is caused by the fact that LANG environment variable is set to a locale other than C or POSIX, while only these two locales are present with glibc-minimal-langpack installed.
The warning can be suppressed either by explicitly setting LANG environment variable to C or POSIX, or by setting MAN_NO_LOCALE_WARNING variable.
Comment 4 Yu Watanabe 2016-03-14 20:09:32 EDT
Thanks. I confirm that the message is suppressed by setting LANG=C or MAN_NO_LOCALE_WARNING=1.
I hope that the fix is also applied to F24.
Comment 5 Nikola Forró 2016-03-15 06:05:30 EDT
(In reply to Yu Watanabe from comment #4)
> I hope that the fix is also applied to F24.
It is not, because the bug was reported against rawhide.
I'm reopening this for F24.
Comment 7 Fedora Update System 2016-03-15 08:51:05 EDT
man-db-2.7.5-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bc305c4b1e
Comment 8 Fedora Update System 2016-03-15 17:30:22 EDT
man-db-2.7.5-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bc305c4b1e
Comment 9 Fedora Update System 2016-03-26 14:07:11 EDT
man-db-2.7.5-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.