Bug 1314637 - SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.
Summary: SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Lukas Vrabec 🐦
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker abrt_hash:b83942374b9...
: 1300456 (view as bug list)
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-04 06:44 UTC by Petr Schindler
Modified: 2016-05-20 11:48 UTC (History)
17 users (show)

Fixed In Version: selinux-policy-3.13.1-179.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-20 11:48:18 UTC


Attachments (Terms of Use)

Description Petr Schindler 2016-03-04 06:44:05 UTC
Description of problem:
This sealert appears right after I log in to system after boot.
SELinux is preventing fwupd from 'write' accesses on the directory 0000:00:02.0.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that fwupd should be allowed write access on the 0000:00:02.0 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep fwupd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:fwupd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sysfs_t:s0
Target Objects                0000:00:02.0 [ dir ]
Source                        fwupd
Source Path                   fwupd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-175.fc25.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc6.git1.1.fc25.x86_64 #1
                              SMP Wed Mar 2 15:40:15 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-03-04 06:55:35 CET
Last Seen                     2016-03-04 07:40:26 CET
Local ID                      50584a5f-909c-44f4-8dab-1fa0b7c1c03c

Raw Audit Messages
type=AVC msg=audit(1457073626.341:358): avc:  denied  { write } for  pid=2709 comm="fwupd" name="0000:00:02.0" dev="sysfs" ino=6227 scontext=system_u:system_r:fwupd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sysfs_t:s0 tclass=dir permissive=1


Hash: fwupd,fwupd_t,sysfs_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-175.fc25.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc6.git1.1.fc25.x86_64
type:           libreport

Potential duplicate: bug 1300456

Comment 1 Petr Schindler 2016-03-15 09:04:45 UTC
This bug still happens on Alpha-1 compose (https://kojipkgs.fedoraproject.org/compose/24/Fedora-24-20160314.1/)

I propose this as Final Blocker. This bug violates the final criterion: "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop."

Comment 2 Lukas Vrabec 🐦 2016-03-16 11:26:54 UTC
*** Bug 1300456 has been marked as a duplicate of this bug. ***

Comment 3 Zdenek Chmelar 2016-03-19 21:50:26 UTC
Description of problem:
right after login to gnome

Version-Release number of selected component:
selinux-policy-3.13.1-176.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport

Comment 4 Dan Mossor [danofsatx] 2016-03-29 16:59:26 UTC
+1 Blocker. Should be no AVCs on released product.

Comment 5 Kamil Páral 2016-03-29 17:17:43 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Final) - violates "There must be no SELinux denial notifications or crash notifications on boot of or during installation from a release-blocking live image, or at first login after a default install of a release-blocking desktop." It's not clear whether this is at all hardware-dependent, but even if it is, it's clear many people are hitting it, enough to take it as a blocker

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29

Comment 6 Kamil Páral 2016-05-16 17:44:47 UTC
This needs testing from QA.

Comment 7 Adam Williamson 2016-05-19 21:09:04 UTC
The intended fix for this went stable long ago, so it should not be happening with current media. If anyone can verify that we can close the bug.

Comment 8 Petr Schindler 2016-05-20 11:48:18 UTC
Works for me with stable version (selinux-policy-3.13.1-185.fc24.noarch). So I'm closing this.


Note You need to log in before you can comment on or make changes to this bug.