Bug 1314658 - trying to access www.seznam.cz crashes webkit
trying to access www.seznam.cz crashes webkit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
: 1317201 1318824 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 03:02 EST by Jan Synacek
Modified: 2016-04-06 11:59 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-25 10:10:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bt plain (68.78 KB, text/plain)
2016-03-07 03:03 EST, Jan Synacek
no flags Details
bt full (395.01 KB, text/plain)
2016-03-07 03:03 EST, Jan Synacek
no flags Details
bt full all threads (457.01 KB, text/plain)
2016-03-07 03:04 EST, Jan Synacek
no flags Details
File: backtrace (97.70 KB, text/plain)
2016-03-20 16:01 EDT, Giulio 'juliuxpigface'
no flags Details
backtrace (webkitgtk4-2.12.0-1.fc24) (90.34 KB, text/plain)
2016-03-24 18:49 EDT, Giulio 'juliuxpigface'
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
WebKit Project 155109 None None None 2016-03-07 08:39 EST

  None (edit)
Description Jan Synacek 2016-03-04 03:02:24 EST
Description of problem:
I'm getting the "Oops! Something went wrong while displaying this page..." page when trying to access www.seznam.cz. The logs show:

Mar 04 08:57:05 ntb-work systemd-coredump[3204]: Process 3126 (WebKitWebProces) of user 17912 dumped core.


Version-Release number of selected component (if applicable):
epiphany-3.19.91-1.fc24.x86_64
webkitgtk-2.4.9-10.fc24.x86_64


Steps to Reproduce:
1. epiphany www.seznam.cz


Actual results:
The page is not displayed.


Expected results:
The page is displayed without problems.
Comment 1 Jan Synacek 2016-03-04 06:57:37 EST
Trying to browse https://extensions.gnome.org/ also crashes.
Comment 2 Michael Catanzaro 2016-03-04 10:13:20 EST
(In reply to Jan Synacek from comment #0)
> Description of problem:
> I'm getting the "Oops! Something went wrong while displaying this page..."
> page when trying to access www.seznam.cz. The logs show:
> 
> Mar 04 08:57:05 ntb-work systemd-coredump[3204]: Process 3126
> (WebKitWebProces) of user 17912 dumped core.

Please post a backtrace for the WebKitWebProcess using 'coredumpctl gdb' so we can see what's wrong, thanks.

> Version-Release number of selected component (if applicable):
> epiphany-3.19.91-1.fc24.x86_64
> webkitgtk-2.4.9-10.fc24.x86_64

Just for the record, Epiphany is actually using the 'webkitgtk4' Fedora packages. The 'webkitgtk' package is insecure and obsolete.

(In reply to Jan Synacek from comment #1)
> Trying to browse https://extensions.gnome.org/ also crashes.

This is unrelated, see https://bugs.webkit.org/show_bug.cgi?id=154891
Comment 3 Jan Synacek 2016-03-07 03:02:43 EST
$ rpm -q webkitgtk4
webkitgtk4-2.11.91-1.fc24.x86_64

Backtraces incoming.
Comment 4 Jan Synacek 2016-03-07 03:03 EST
Created attachment 1133678 [details]
bt plain
Comment 5 Jan Synacek 2016-03-07 03:03 EST
Created attachment 1133679 [details]
bt full
Comment 6 Jan Synacek 2016-03-07 03:04 EST
Created attachment 1133680 [details]
bt full all threads
Comment 7 Michael Catanzaro 2016-03-07 08:39:42 EST
OK thanks, I posted this upstream.
Comment 8 Michael Catanzaro 2016-03-07 20:33:08 EST
Hopefully fixed by http://trac.webkit.org/changeset/197716, but nobody was able to reproduce. I'll propose it as a backport for WebKitGTK+ 2.11.92, and you can complain if it's still broken after the next update.
Comment 9 Jan Synacek 2016-03-08 02:40:36 EST
That was fast, thank you!
Comment 10 Michael Catanzaro 2016-03-12 21:02:50 EST
*** Bug 1317201 has been marked as a duplicate of this bug. ***
Comment 11 Michael Catanzaro 2016-03-17 20:10:29 EDT
*** Bug 1318824 has been marked as a duplicate of this bug. ***
Comment 12 Giulio 'juliuxpigface' 2016-03-20 16:01:42 EDT
Similar problem has been detected:

Fedora 24 Alpha 1.6 Workstation, qemu-kvm.

I've tried to add an online account, selecting Facebook as provider.
If I switch to caps lock while typing the password, the dialog crashes.

Of course, this happens to other web services, like Google and Microsoft.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 18
crash_function: WebCore::RenderObject::RenderObjectBitfields::isInline
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     3368
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
package:        webkitgtk4-2.11.91-1.fc24
reason:         WebKitWebProcess killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 Giulio 'juliuxpigface' 2016-03-20 16:01:50 EDT
Created attachment 1138359 [details]
File: backtrace
Comment 14 Jan Synacek 2016-03-21 02:11:11 EDT
I no longer experience any crashes with webkitgtk4-2.11.92-2.fc24.x86_64.
Comment 15 Giulio 'juliuxpigface' 2016-03-22 16:11:10 EDT
Well, since the webkitgtk's version which is currently in F24's repo (webkitgtk4-2.11.91-1.fc24) is the one containing this bug... I think it would be good if we include it on the "F24 Alpha CommonBugs page".

Enabling the caps lock key in the password field, is enough in order to trigger the issue. I think this is a fairly common behavior.
Comment 16 Fedora Update System 2016-03-22 19:04:25 EDT
webkitgtk4-2.12.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d9db9ab80
Comment 17 Fedora Update System 2016-03-23 15:56:22 EDT
webkitgtk4-2.12.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8d9db9ab80
Comment 18 Michael Catanzaro 2016-03-24 18:31:08 EDT
(In reply to Giulio 'juliuxpigface' from comment #12)
> I've tried to add an online account, selecting Facebook as provider.
> If I switch to caps lock while typing the password, the dialog crashes.
> 
> Of course, this happens to other web services, like Google and Microsoft.

Hi, you reported in Bodhi that you hit this with 2.12.0. Could you attach a backtrace for the crashing WebKitWebProcess please?
Comment 19 Giulio 'juliuxpigface' 2016-03-24 18:49 EDT
Created attachment 1140176 [details]
backtrace (webkitgtk4-2.12.0-1.fc24)
Comment 20 Michael Catanzaro 2016-03-25 10:10:21 EDT
OK thanks, I reopened the upstream bug report with this backtrace, and removed the bug reference from the 2.12 update.
Comment 21 Michael Catanzaro 2016-03-25 12:02:02 EDT
(In reply to Michael Catanzaro from comment #20)
> OK thanks, I reopened the upstream bug report with this backtrace, and
> removed the bug reference from the 2.12 update.

It's apparently a different bug, WebKit #155885.
Comment 22 Michael Catanzaro 2016-03-25 19:55:36 EDT
(In reply to Michael Catanzaro from comment #21)
> (In reply to Michael Catanzaro from comment #20)
> > OK thanks, I reopened the upstream bug report with this backtrace, and
> > removed the bug reference from the 2.12 update.
> 
> It's apparently a different bug, WebKit #155885.

Should be fixed by http://trac.webkit.org/changeset/198701, will get it into 2.12.1.
Comment 23 Heiko Adams 2016-03-26 06:00:25 EDT
Similar problem has been detected:

Opened https://extensions.gnome.org in epiphany and tried to update some extensions

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 26
crash_function: WebCore::RenderObject::RenderObjectBitfields::isInline
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     6732
kernel:         4.4.5-300.fc23.x86_64
package:        webkitgtk4-2.12.0-1.fc24
reason:         WebKitWebProcess killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 24 Michael Catanzaro 2016-04-06 11:59:31 EDT
*** Bug 1318824 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.