Bug 1314693 - Fix rule setting SYSTEMD_READY=0 for DM devices (like multipath) which may cause improper automatic unmounts
Fix rule setting SYSTEMD_READY=0 for DM devices (like multipath) which may ca...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: systemd-maint
Radka Skvarilova
: ZStream
Depends On: 1312011
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 04:19 EST by Libor Miksik
Modified: 2016-09-13 05:01 EDT (History)
12 users (show)

See Also:
Fixed In Version: systemd-219-19.el7_2.7
Doc Type: Bug Fix
Doc Text:
The device mapper sets the DM_UDEV_DISABLE_OTHER_RULES_FLAG signal to indicate that other rules should not react to the event. However, systemd previously considered the related device not to be ready for use, which is only true for the ADD event. As a consequence, overlaying file systems on the devices were unmounted even if only one path became unavailable, but other paths were still accessible. With this update, the device is marked as unusable only in case of ADD events, and CHANGE events are ignored. As a result, file systems are no longer unmounted if a CHANGE event occurs.
Story Points: ---
Clone Of: 1312011
Environment:
Last Closed: 2016-03-31 17:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Miksik 2016-03-04 04:19:01 EST
This bug has been copied from bug #1312011 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 7 errata-xmlrpc 2016-03-31 17:55:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0181.html

Note You need to log in before you can comment on or make changes to this bug.