Bug 1314695 - Upgrade from 6.2 snap2 to snap2.1 failed at step errata_import failed
Upgrade from 6.2 snap2 to snap2.1 failed at step errata_import failed
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: 6.2
Assigned To: Mike McCune
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 04:24 EST by Sachin Ghai
Modified: 2016-07-27 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:04:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14241 None None None 2016-03-21 13:53 EDT

  None (edit)
Description Sachin Ghai 2016-03-04 04:24:28 EST
Description of problem: I was trying upgrade from sat6.2 snap2 to snap2.1. And I was using only custom contents on my setup. And upgrade got failed at step:


[root@cloud-qe-7 ~]# foreman-installer --scenario katello --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_databases...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: migrate_gutterball...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/foreman-installer/katello.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: errata_import (this may take a while) ...
Upgrade step errata_import failed. Check logs for more information.


I'm not sure if its early to perform upgrade, but here we are doing upgrade form 6.2 to 6.2 with diff snaps without lot of changes. So I think it should work.

Here are the logs from production.log:

[ INFO 2016-03-04 04:07:56 main] Upgrade Step: errata_import (this may take a while) ...
[ERROR 2016-03-04 04:08:09 main] Ignoring ruby-libvirt-0.5.2 because its extensions are not built.  Try: gem pristine ruby-libvirt --version 0.5.2
/opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.17.0/lib/docker.rb:103: warning: circular argument reference - connection
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.4/config/routes/overrides.rb:3: warning: already initialized constant Katello::WhitelistConstraint::PATHS
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.4/config/routes/overrides.rb:3: warning: previous definition of PATHS was here
rake aborted!
NameError: uninitialized constant Actions::Katello::System::GenerateApplicability
/opt/theforeman/tfm/root/usr/share/gems/gems/foreman_hooks-0.3.9/lib/foreman_hooks.rb:83:in `load_missing_constant_with_hooks'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.4/lib/katello/tasks/upgrades/2.1/import_errata.rake:39:in `block (4 levels) in <top (required)>'
Tasks: TOP => katello:upgrades:2.1:import_errata
(See full trace by running task with --trace)
Importing Errata
Generating applicability for 1 Content Hosts



Version-Release number of selected component (if applicable):
upgrade from sat6.2 snap2 to sat6.2 snap2.1

How reproducible:
always

Steps to Reproduce:
1. foreman-installer --scenario katello --upgrade
2.
3.

Actual results:
Upgrade step errata_import failed. Check logs for more information.


Expected results:
upgrade should work atleast between one snap of 6.2 to other.

Additional info:
Comment 4 Sachin Ghai 2016-03-31 03:31:03 EDT
Verified with sat6.2 beta snap6

I upgraded Sat 6.2 from snap5 to snap6 and upgrade was completed successfully. I don't find any issue neither on console nor in logs.

 ~]# foreman-installer --scenario katello --upgrade
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_databases...
Upgrade Step: migrate_pulp...
Upgrade Step: start_httpd...
Upgrade Step: migrate_candlepin...
Upgrade Step: migrate_foreman...
Upgrade Step: migrate_gutterball...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/foreman-installer/katello.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: import_package_groups (this may take a while) ...
Upgrade Step: import_rpms (this may take a while) ...
Upgrade Step: import_distributions (this may take a while) ...
Upgrade Step: import_puppet_modules (this may take a while) ...
Upgrade Step: import_subscriptions (this may take a while) ...
Upgrade Step: remove_elasticsearch...
Upgrade Step: remove_docker_v1_content (this may take a while) ...
Katello upgrade completed!
Comment 7 errata-xmlrpc 2016-07-27 05:04:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.