Bug 1314705 - [ovirt-node] Can't register node to engine through TUI
[ovirt-node] Can't register node to engine through TUI
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.17.999
Assigned To: Dan Kenigsberg
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 05:04 EST by Gonza
Modified: 2016-08-22 08:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 08:27:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
register.log (7.12 KB, text/plain)
2016-03-04 05:04 EST, Gonza
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54384 master MERGED vdsm.host.uuid: eliminate obsoleted argument "legacy" 2016-03-07 03:38 EST

  None (edit)
Description Gonza 2016-03-04 05:04:02 EST
Created attachment 1133133 [details]
register.log

Description of problem:
When registering a node to an engine through the node TUI an error message is displayed with:
Cannot connect to engine. 10-34-60-38.rhev.lab.eng.brq.redhat.com matches the FQDN of Engine?
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 478, in main
    reg.host_uuid()
  File "/usr/lib/python2.7/site-packages/vdsm/tool/register.py", line 260, in host_uuid
    self.uuid = host.uuid(legacy=False)
TypeError: __call__() got an unexpected keyword argument 'legacy'

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.6-0.999.201603032115.el7.centos.iso
ovirt-engine-3.6.0-0.0.master.20150804111407.git122a3a0.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install node
2. Configure network through TUI
3. Register to engine FQDN

Actual results:
Can't register

Expected results:
Node successfully registered

Additional info:
Attached register.log
Comment 1 Fabian Deutsch 2016-03-04 05:17:53 EST
Setting prio of high, because it's blocking another bug
Comment 2 Gonza 2016-03-04 05:18:53 EST
VDSM Version:
vdsm-4.17.999-675.git520ffde.el7.centos.noarch
Comment 3 Dan Kenigsberg 2016-03-06 08:32:01 EST
This is a regression due to commit e3409136, since @memoized function does not accept named arguments.
Comment 4 Oved Ourfali 2016-03-07 02:57:23 EST
As far as I understand it only happens in 4.0.
Gonza - why haven't you specified the version you're working with?
Also, all dependent bugs are VERIFIED.
Reducing to medium.
Comment 5 Pavol Brilla 2016-08-22 04:20:11 EDT
RHEV-H 7.2-20160711.0.el7ev (3.6.8 live release) succesfully added to Red Hat Virtualization Manager Version: 4.0.2.6-0.1.el7ev ( RHVM 4 GA candidate )

Note You need to log in before you can comment on or make changes to this bug.