Bug 131471 - missing symbolic link "/usr/lib/libodbcinst.so"
Summary: missing symbolic link "/usr/lib/libodbcinst.so"
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: unixODBC (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-01 17:00 UTC by Thomas Antony
Modified: 2013-07-03 03:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 21:45:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Antony 2004-09-01 17:00:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040616

Description of problem:
Some third-party rpm's require "/usr/lib/libodbcinst.so" and will fail
to install for the reason of failed dependencies, because
"/usr/lib/libodbcinst.so is missing. A symbolic link from
/usr/lib/libodbcinst.so.1.0.0 to "/usr/lib/libodbcinst.so" would
resolve the dependencies.

Version-Release number of selected component (if applicable):
unixODBC-2.2.8-5

How reproducible:
Always

Steps to Reproduce:
1. Install unixODBC

Additional info:

Comment 1 Tom Lane 2004-09-23 18:05:46 UTC
Actually, the symlink does exist, but for some reason it's in the
unixODBC-devel package not the main unixODBC package.  This seems
weird to me too; I am making inquiries to try to find out why it was
done that way.

Comment 2 Tom Lane 2004-11-11 21:45:01 UTC
The consensus seems to be that this is the intended packaging setup
--- the unversioned .so symlink is supposed to be where it is.  So the
problem is with the third-party RPMs.  They should be depending on a
versioned .so name.


Note You need to log in before you can comment on or make changes to this bug.