Bug 1314716 - Installer: advanced config database logging doesn't add command and audit loggers for domain mode
Installer: advanced config database logging doesn't add command and audit log...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Installer (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.3.0
Assigned To: Van Halbert
Jan Stastny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 05:31 EST by Jan Stastny
Modified: 2016-08-24 07:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:49:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4050 Critical Resolved database logging doesn't add command and audit loggers for domain mode 2016-04-20 01:26 EDT

  None (edit)
Description Jan Stastny 2016-03-04 05:31:31 EST
Description of problem:
When installing server with Advanced config option and selecting database logging, than no org.teiid.COMMAND_LOG or org.teiid.AUDIT_LOG category loggers are present in domain.xml for ha and full-ha profile.
The reason seems to be simple: there is no command to actually add them in cli-scripts/teiid-add-database-logger-domain.cli . 
In the script the default file loggers are removed, but they're not replaced with anything.
Comment 1 Thomas Hauser 2016-03-09 13:32:24 EST
Confirmed, when comparing to the standalone install script, the loggers themselves are not added but the handlers are added.
Comment 2 JBoss JIRA Server 2016-03-09 14:23:03 EST
Van Halbert <vhalbert@jboss.org> updated the status of jira TEIID-4050 to Resolved

Note You need to log in before you can comment on or make changes to this bug.