Bug 1314728 - Build kubernetes for AH 7.2.3
Build kubernetes for AH 7.2.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kubernetes (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 05:56 EST by Jan Chaloupka
Modified: 2016-04-15 11:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: kubernetes-1.2.0-0.8.alpha1.gitb57e8bd.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:26:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0528 normal SHIPPED_LIVE kubernetes bug fix and enhancement update 2016-03-31 23:20:49 EDT

  None (edit)
Comment 7 errata-xmlrpc 2016-03-31 19:26:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0528.html
Comment 8 Kevin Fox 2016-04-03 18:59:04 EDT
This mentions disabling extensions/v1beta1. Why was that done? It was very useful for certain things.
Comment 9 Jan Chaloupka 2016-04-04 02:20:51 EDT
extensions/v1beta1 was enabled by default which caused kubelet to fail with the default configuration. I changed the default setting to disable the extension by default (as it was in the previous releases). It can be always reenabled via --runtime-config option of apiserver.
Comment 10 Kevin Fox 2016-04-04 11:50:17 EDT
KUBE_API_ARGS="--runtime-config=v1,extensions/v1beta1=true"

did enable it. thanks.

Is there a rough timeline for final 1.2?
Comment 11 Jan Chaloupka 2016-04-05 04:20:38 EDT
> Is there a rough timeline for final 1.2?

Not aware of. Hoping for 7.2.4 release.
Comment 12 Jan Chaloupka 2016-04-15 11:25:31 EDT
Kevin,

checking the apiserver patches, disabling of extensions/v1beta1 was actually never done for RHEL. I applied it on Fedora only.

Anyway, kubernetes-1.2.0 shipping in 7.2.4 if nothing goes wrong [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1327666

Note You need to log in before you can comment on or make changes to this bug.