Bug 1314732 - Telemetry is not configured in nova.conf
Telemetry is not configured in nova.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: rc
: 10.0 (Newton)
Assigned To: Pradeep Kilambi
Arik Chernetsky
: Automation, AutomationBlocker, TestOnly, Triaged
Depends On: 1314725
Blocks: 1335596 1356451
  Show dependency treegraph
 
Reported: 2016-03-04 06:08 EST by tkammer
Modified: 2016-12-14 10:27 EST (History)
14 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.2.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, while deploying Red Hat OpenStack Platform 8 using director, the Telemetry service was not configured in Compute, causing some of the OpenStack Integration Test Suite tests to fail. With this update, the OpenStack Telemetry service is configured in the Compute configuration. As a result, the notification driver is set correctly and the OpenStack Integration Test Suite tests pass.
Story Points: ---
Clone Of: 1314725
Environment:
Last Closed: 2016-12-14 10:27:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tkammer 2016-03-04 06:08:21 EST
Description of problem:
When deploying OSP8 using director the telemetry is not configured in nova:
[root@overcloud-novacompute-0 ~]# grep 'notification_driver' /etc/nova/nova.conf 
#notification_driver =

This causes the following failures in tempest:
tempest.api.telemetry.test_telemetry_notification_api.TelemetryNotificationAPITestJSON.test_check_nova_notification

To fix this, we need to edit all the compute nodes /etc/nova/nova.conf and change the notification_driver option to messagingv2.
Then restart the openstack-nova-compute and openstack-ceilometer-compute services.

[root@overcloud-novacompute-0 ~]# crudini --set /etc/nova/nova.conf  DEFAULT  notification_driver messagingv2
[root@overcloud-novacompute-0 ~]# systemctl restart openstack-nova-compute openstack-ceilometer-compute


How reproducible:
100%

Steps to Reproduce:
1. deploy OSP8 using osp-director
2. run the above test
Comment 1 Mike Burns 2016-04-07 17:14:44 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 3 Yurii Prokulevych 2016-10-14 08:05:12 EDT
grep -ri "notification_driver" /usr/share/openstack-tripleo-heat-templates/puppet/services/nova-*
/usr/share/openstack-tripleo-heat-templates/puppet/services/nova-base.yaml:
nova::notification_driver: messagingv2

[root@compute-0 ~ ]# grep messaging /etc/nova/nova.conf 
[oslo_messaging_rabbit]
[oslo_messaging_notifications]
driver=messagingv2
Comment 6 errata-xmlrpc 2016-12-14 10:27:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.