Bug 1314762 - wine-desktop package remove problem
Summary: wine-desktop package remove problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-04 12:26 UTC by Stefan Dordevic
Modified: 2016-11-28 05:48 UTC (History)
5 users (show)

Fixed In Version: wine-1.8.5-2.el7 wine-1.8.5-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-25 02:51:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Stefan Dordevic 2016-03-04 12:26:29 UTC
Description of problem:

When wine is installed from epel7 repository, yum print the error lines regarding the wine-desktop package. 

Installing : wine-desktop-.8.1-1.el7.noarch                                                                                                                                                  33/43
error reading information on service wine: No such file or directory
error reading information on service wine: No such file or directory

Seems that this cause problem when removing wine-desktop package.

wine-desktop package can't be remove regular

# rpm -e wine-desktop-1.8.1-1.el7.noarch
error reading information on service wine: No such file or directory
error: %preun(wine-desktop-1.8.1-1.el7.noarch) scriptlet failed, exit status 1
error: wine-desktop-1.8.1-1.el7.noarch: erase failed

note for qe:
There is a workaround for uninsgtalling wine-desktop this:
# rpm --nopreun -e wine-desktop-1.8.1-1.el7.noarch
  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. yum install --enablerepo=epel -y wine

2. rpm -e wine-desktop-1.8.1-1.el7.noarch
error reading information on service wine: No such file or directory
error: %preun(wine-desktop-1.8.1-1.el7.noarch) scriptlet failed, exit status 1
error: wine-desktop-1.8.1-1.el7.noarch: erase failed

Actual results:

wine-desktop remove fail

Expected results:

wine-desktop removed

Additional info:

Comment 2 Alessandro Suardi 2016-08-21 19:40:25 UTC
Happens with wine-desktop-1.8.3-1.el7.noarch as well:

[root@slick log]# rpm -e wine-desktop.noarch
error reading information on service wine: No such file or directory
error: %preun(wine-desktop-1.8.3-1.el7.noarch) scriptlet failed, exit status 1
error: wine-desktop-1.8.3-1.el7.noarch: erase failed

And workaround posted works for me too, thanks:

[root@slick log]# rpm --nopreun -e wine-desktop.noarch
[root@slick log]#

Comment 3 Fedora Update System 2016-11-08 06:23:34 UTC
wine-1.8.5-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-afab05a526

Comment 4 Fedora Update System 2016-11-08 06:27:49 UTC
wine-1.8.5-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8014ecd6ea

Comment 5 Fedora Update System 2016-11-10 04:20:05 UTC
wine-1.8.5-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-afab05a526

Comment 6 Fedora Update System 2016-11-10 06:47:43 UTC
wine-1.8.5-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8014ecd6ea

Comment 7 Fedora Update System 2016-11-25 02:51:50 UTC
wine-1.8.5-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-11-28 05:48:06 UTC
wine-1.8.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.