Bug 1314777 - perl-IO-Pty-Easy-0.09-5.fc25 FTBFS: t/read-write.t test fails randomly
perl-IO-Pty-Easy-0.09-5.fc25 FTBFS: t/read-write.t test fails randomly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-IO-Pty-Easy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 08:07 EST by Petr Pisar
Modified: 2016-03-15 07:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-IO-Pty-Easy-0.09-6.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 07:14:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 113038 None None None 2016-03-15 07:14 EDT
CPAN 95702 None None None 2016-03-14 12:38 EDT
CPAN 96826 None None None 2016-03-04 08:07 EST

  None (edit)
Description Petr Pisar 2016-03-04 08:07:53 EST
perl-IO-Pty-Easy-0.09-5.fc25 fails to build in F25 sometimes because a test can fail:

%check phase:
#   Failed test 'write returns undef on timeout'
#   at t/read-write.t line 18.
#          got: '11'
#     expected: undef
# Looks like you failed 1 test of 5.
t/read-write.t ............ 
Dubious, test returned 1 (wstat 256, 0x100)
Failed

Reproducer is:

$ while (perl -Ilib t/read-write.t); do :;done

It looks like there is a race in the test.
Comment 1 Petr Pisar 2016-03-14 12:57:14 EDT
I applied a fix I proposed to the upstream. But it fails in koji. It actually fails if tests' stdin is not a TTY. This looks like genuine bug in the module.
Comment 2 Petr Pisar 2016-03-15 07:14:22 EDT
It loks like a bug in the module documentation. I adapted the test.

Note You need to log in before you can comment on or make changes to this bug.