Bug 131478 - up2date when upgraded replaced development sources and reverted to up2date sources for Fedora Core 2, when I was previously using FC3t1
Summary: up2date when upgraded replaced development sources and reverted to up2date so...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-01 17:35 UTC by Xander D Harkness
Modified: 2016-06-07 22:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 15:10:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Xander D Harkness 2004-09-01 17:35:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
I ran up2date -u against my normal rawhide up2date sources.  Up2date
installed new sources without providing a sources.rpmnew or
sources.rpmsave versions.

I tried rerunning up2date to obtain the rest of my updates due and
up2date reported all packages current.  It checked URLs for Fedora Core 2

Version-Release number of selected component (if applicable):
up2date-4.3.29-6

How reproducible:
Didn't try

Steps to Reproduce:
1.up2date to latest version of up2date in rawhide using the
development sources
2.up2date will install and alter the sources to pull packages from
without providing a backup
3.
    

Actual Results:  Up2date rpm does provide a backup of the sources file
and replaces the existing file

Expected Results:  I would expect the new up2date sources file to be
called sources.rpmnew to allow new URLs to be migrated

Additional info:

Comment 1 Matthew Miller 2006-07-10 22:50:57 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!


Comment 2 John Thacker 2006-10-29 15:10:31 UTC
Closing per lack of response to previous comment.  If this still occurs on FC3
or FC4 and is a security issue, please assign to Fedora Legacy and the
appropriate version.  The bug could also be filed against RHEL if it is relevant
there.

up2date has been replaced by pirut and pup in FC5 and FC6, the still fully
supported versions of Fedora Core, so this bug will not be fixed unless it is a
security issue.


Note You need to log in before you can comment on or make changes to this bug.