This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1314800 - perl-Perl-Tidy-Sweetened-1.07-2.fc25 FTBFS: tests fail
perl-Perl-Tidy-Sweetened-1.07-2.fc25 FTBFS: tests fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Perl-Tidy-Sweetened (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jitka Plesnikova
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 09:25 EST by Petr Pisar
Modified: 2016-03-26 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Perl-Tidy-Sweetened-1.07-3.fc25 perl-Perl-Tidy-Sweetened-1.10-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:09:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-03-04 09:25:33 EST
perl-Perl-Tidy-Sweetened-1.07-2.fc25 fails to build in F25 because tests fail:

t/p5-mop.t ..................... ok
#   Failed test '5.20 annoymous sub: matches'
#   at t/lib/TidierTests.pm line 83.
# +---+-------------------------+-----------------------+
# | Ln|Got                      |Expected               |
# +---+-------------------------+-----------------------+
# |  1|'$j->map(                |'$j->map(              |
# *  2|    sub ( $x, $ = 0 ) {  |    sub($x,$ = 0) {    *
# |  3|        $x->method();    |        $x->method();  |
# |  4|    }                    |    }                  |
# |  5|);                       |);                     |
# |  6|'                        |'                      |
# +---+-------------------------+-----------------------+
#   Failed test '5.20 annoymous sub 2 : matches'
#   at t/lib/TidierTests.pm line 83.
# +---+------------------------------+--------------------------+
# | Ln|Got                           |Expected                  |
# +---+------------------------------+--------------------------+
# *  1|'my $x = sub ( $x, $ = 0 ) {  |'my $x = sub($x,$ = 0) {  *
# |  2|    $x->method();             |    $x->method();         |
# |  3|};                            |};                        |
# |  4|'                             |'                         |
# +---+------------------------------+--------------------------+
# Looks like you failed 2 tests of 32.
t/perl-signatures.t ............ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/32 subtests
Comment 1 Petr Pisar 2016-03-04 09:29:00 EST
My unreliable build root comparator shows:

Removed packages:
	gdb-7.10.90.20160211
	glibc-2.22.90
	glibc-common-2.22.90
	glibc-devel-2.22.90
	glibc-headers-2.22.90
	perl-IO-Tty-1.12
	perl-IPC-Run-0.94
	perl-Text-Diff-1.43
	perl-version-0.99.12
	perltidy-20150815
	python3-pyparsing-2.0.7
	python3-setuptools-20.1.1
Added packages:
	binutils-2.26
	cryptsetup-libs-1.7.1
	device-mapper-1.02.118
	device-mapper-libs-1.02.118
	fedora-release-25
	gc-7.4.2
	glibc-2.23.90
	glibc-common-2.23.90
	glibc-devel-2.23.90
	glibc-headers-2.23.90
	glibc-langpack-zu-2.23.90
	krb5-libs-1.14.1
	libicu-56.1
	libseccomp-2.3.0
	libselinux-2.5
	libsemanage-2.5
	libsepol-2.5
	nss-3.22.2
	nss-softokn-3.22.2
	nss-softokn-freebl-3.22.2
	nss-sysinit-3.22.2
	nss-tools-3.22.2
	nss-util-3.22.2
	pcre-8.38
	perl-Text-Diff-1.44
	perl-version-0.99.14
	perltidy-20160302
	python3-pyparsing-2.1.0
	setup-2.10.2
	systemd-229
	systemd-libs-229

So I suspect perl-Text-Diff or perltidy.
Comment 2 Jitka Plesnikova 2016-03-08 07:24:23 EST
The failure is caused by updated perltidy
Comment 3 Fedora Update System 2016-03-11 06:27:48 EST
perl-Perl-Tidy-Sweetened-1.07-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-137894a8dd
Comment 4 Fedora Update System 2016-03-11 14:25:28 EST
perl-Perl-Tidy-Sweetened-1.07-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-137894a8dd
Comment 5 Fedora Update System 2016-03-14 09:26:45 EDT
perl-Perl-Tidy-Sweetened-1.10-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-78d1d43064
Comment 6 Fedora Update System 2016-03-15 17:31:47 EDT
perl-Perl-Tidy-Sweetened-1.10-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-78d1d43064
Comment 7 Fedora Update System 2016-03-26 14:09:00 EDT
perl-Perl-Tidy-Sweetened-1.10-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.