Bug 1314811 - katello-backup tries to run with invalid flags
katello-backup tries to run with invalid flags
Status: CLOSED DUPLICATE of bug 1250185
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Backup & Restore (Show other bugs)
6.1.7
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Christine Fouant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 10:07 EST by Jason Berry
Modified: 2016-03-04 10:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 10:20:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Berry 2016-03-04 10:07:11 EST
Description of problem:
katello-backup tries to run and fails if you pass invalid flags or data

Version-Release number of selected component (if applicable):
6.1.7

How reproducible:
Every time

Steps to Reproduce:
1.run "katello-backup --help"

Actual results:
It tries to run, and throws a bunch of errors, and stops services

Expected results:
It shouldn't accept invalid parameters/flags
Comment 1 Evgeni Golov 2016-03-04 10:20:22 EST

*** This bug has been marked as a duplicate of bug 1250185 ***

Note You need to log in before you can comment on or make changes to this bug.