Bug 1314821 - Drop dependency on elasticsearch
Drop dependency on elasticsearch
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: hguemar
Avi Avraham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 10:45 EST by Flavio Percoco
Modified: 2016-04-26 11:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: openstack-glance-11.0.1-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:33:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Percoco 2016-03-04 10:45:57 EST
In OSP7 glance had a dependency on elasticsearch for the glance-search process. This process has been spawned up into its own service called Searchlight and the code in Glance doesn't exist anymore.

We should remove the dependency on python-elasticsearch
Comment 2 hguemar 2016-03-07 04:25:33 EST
Fixed (and backported in RDO Liberty/Mitaka)
Comment 4 Avi Avraham 2016-03-27 09:01:07 EDT
Verified - No elastic search packaged was installed on glance server 
Was verified on ospd8
Comment 5 errata-xmlrpc 2016-04-07 17:33:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.