Bug 131485 - Current xfprint missing /sbin/ldconfig, %find_lang and misc fixes
Current xfprint missing /sbin/ldconfig, %find_lang and misc fixes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-01 14:01 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 17:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to the spec for proper %find_lang use. (1.56 KB, patch)
2004-09-01 14:01 EDT, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2004-09-01 14:01:19 EDT
Description of problem:
The translations in the package are included with "%{_datadir}/*",
which is wrong because the package then owns /usr/share/locale and
many of its sub-dirs, and doesn't properly color the language files
(tags them with their language in the rpm). Also, it contains a
library, but doesn't run /sbin/ldconfig in its scriplets as it should.

Version-Release number of selected component (if applicable):
xfprint-4.0.6-1

Additional info:
- Component xfprint is missing from bugzilla.
- The static library should probably be excluded as it's useless
- The description was over 80 columns
- The generic INSTALL file should probably be omitted from %doc
All of the above fixes are in the patch below.
Comment 1 Matthias Saou 2004-09-01 14:01:47 EDT
Created attachment 103353 [details]
Patch to the spec for proper %find_lang use.
Comment 2 Ngo Than 2004-09-01 17:20:54 EDT
i don't think /sbin/ldconfig is needed here. There're only plugins.

i have cleaned up the specfile. It's fixed in 4.0.6-2. Thanks
Comment 3 Ngo Than 2004-09-01 17:36:49 EDT
xfprint.spec is now fixed. thanks

Note You need to log in before you can comment on or make changes to this bug.