Bug 1314869 - Backport of "cyclictest: SMI count/detection via MSR/SMI counter"
Backport of "cyclictest: SMI count/detection via MSR/SMI counter"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rt-tests (Show other bugs)
7.3
x86_64 Linux
unspecified Severity low
: rc
: 7.3
Assigned To: John Kacur
Jiri Kastner
:
Depends On:
Blocks: 1274397
  Show dependency treegraph
 
Reported: 2016-03-04 12:50 EST by Daniel Bristot de Oliveira
Modified: 2016-11-04 01:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of the feature (10.03 KB, patch)
2016-03-04 12:54 EST, Daniel Bristot de Oliveira
no flags Details | Diff
backport of man description of --smi option (566 bytes, patch)
2016-03-04 12:57 EST, Daniel Bristot de Oliveira
no flags Details | Diff

  None (edit)
Description Daniel Bristot de Oliveira 2016-03-04 12:50:35 EST
Description of problem:
The upstream --smi option of cyclictest helps to define if the worst-case latency is or is not caused by SMIs.

I used it on a customer, so I think it is good to have it in the official build.

Version-Release number of selected component (if applicable):
The last version of rt-tests does not have --smi option.
Comment 1 Daniel Bristot de Oliveira 2016-03-04 12:54 EST
Created attachment 1133228 [details]
backport of the feature

cyclictest: SMI count/detection via MSR/SMI counter

Use the MSR/SMI counter on Intel's processor to detect/count SMIs. It is
based on turbostat's implementation.

SMI counting is enabled via --smi argument. When enabled, and additional
field is added on both regular and verbose ouput.

On the regular output, a SMI column shows how many SMIs occurred on
each CPU during cyclictest's execution. For example:

policy: fifo: loadavg: 0.09 0.05 0.02 1/194 2288

T: 0 ( 2285) P:80 I:1000 C:   9975 Min:      2 Act:    3 Avg:    4 Max:   20831 SMI:       2
T: 1 ( 2286) P:80 I:1500 C:   6650 Min:      2 Act:    2 Avg:    5 Max:   19910 SMI:       2
T: 2 ( 2287) P:80 I:2000 C:   4987 Min:      2 Act:    2 Avg:    6 Max:   20811 SMI:       2
T: 3 ( 2288) P:80 I:2500 C:   3990 Min:      2 Act:    3 Avg:    7 Max:   20322 SMI:       2

On verbose output, the last column shows how many SMIs occurred
on each loop. For example:

[  CPU  |   Loop |   Lat |  SMIs  ]
       0:    2156:       2       0
       0:    2157:       2       0
       0:    2158:       2       0
       0:    2159:   20981       2
       1:    1433:       2       0
       1:    1434:       2       0
       1:    1435:       2       0
       1:    1436:       3       0
       1:    1437:       2       0
       1:    1438:       2       0
       1:    1439:   20249       2

Signed-off-by: Daniel Bristot de Oliveira <bristot@redhat.com>
Signed-off-by: John Kacur <jkacur@redhat.com>
Comment 2 Daniel Bristot de Oliveira 2016-03-04 12:57 EST
Created attachment 1133229 [details]
backport of man description of --smi option

cyclictest: Add --smi description on cyclictest man page

Add the description of the --smi command line option of cyclictest.

"--smi  Enable SMI count/detection on processors with SMI count support."

Signed-off-by: Daniel Bristot de Oliveira <bristot@redhat.com>
Signed-off-by: John Kacur <jkacur@redhat.com>
Comment 3 Daniel Bristot de Oliveira 2016-03-04 12:58:38 EST
Brewbuild with the smi.patch:

https://brewweb.devel.redhat.com/taskinfo?taskID=10603781
Comment 4 John Kacur 2016-05-20 08:47:57 EDT
This was added in v0.97, so fixed earlier, but fixed at least in
rt-tests-1.0-1.el7 and up
Comment 9 errata-xmlrpc 2016-11-04 01:14:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2391.html

Note You need to log in before you can comment on or make changes to this bug.