Bug 131491 - Current libselinux is missing %postun /sbin/ldconfig call
Current libselinux is missing %postun /sbin/ldconfig call
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-01 14:45 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 04:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add missing ldconfig call and clean up the spec file. (1.56 KB, patch)
2004-09-01 14:46 EDT, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2004-09-01 14:45:45 EDT
Description of problem:
The current libselinux package has a proper %post scriplet to call
/sbin/ldconfig, but is lacking a similar %postun one.

Version-Release number of selected component (if applicable):
libselinux-1.17.3-1

How reproducible:
Always.

Steps to Reproduce:
1. rpm -q --scripts libselinux-1.17.3-1
  
Actual results:
postinstall scriptlet (using /bin/sh):
# add libselinux to the cache
/sbin/ldconfig

Expected results:
Also see a %postun scriplet.

Additional info:
Attached is a spec file patch that adds it and also cleans up the spec
file by mainly removing stuff that is now unneeded.
Also, I don't understand the reason to have a "Provides:
libselinux.so" in the main package. All applications I can see linked
against libselinux have a proper dependency on the .so.1 versionned
file, so that provides could/should probably be removed.
Comment 1 Matthias Saou 2004-09-01 14:46:34 EDT
Created attachment 103357 [details]
Patch to add missing ldconfig call and clean up the spec file.
Comment 2 Daniel Walsh 2004-09-09 13:05:40 EDT
Fixed in libselinux-1.17.9-1
Comment 3 Matthias Saou 2004-09-16 04:34:37 EDT
Indeed fixed in libselinux-1.17.9-1, but another minor weirdness
slipped in : The package's "Distribution:" tag got "Red Hat FC-3"
instead of the usual "Red Hat Linux" that all other packages have. Is
this normal?
Comment 4 Matthias Saou 2004-09-16 04:53:03 EDT
Never mind the distribution tag, seems like a more general issue of
the build system(s). I've started a thread about it :
http://www.redhat.com/archives/fedora-devel-list/2004-September/msg00753.html

I'll close the bug as RAWHIDE now.

Note You need to log in before you can comment on or make changes to this bug.