Bug 1314924 - Unable to mount AWS EBS to the pod after creating PV/PVC
Unable to mount AWS EBS to the pod after creating PV/PVC
Status: CLOSED DUPLICATE of bug 1313391
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bradley Childs
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-04 16:50 EST by Eric Jones
Modified: 2016-03-09 02:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift Enterprise 3.1.1.6
Last Closed: 2016-03-08 10:42:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Josep 'Pep' Turro Mauri 2016-03-08 04:28:16 EST
(In reply to Eric Jones from comment #0)
> After talking with Huamin Chen, he indicated that this issue has been fixed
> in origin with [0]
> 
> [0]
> https://github.com/openshift/origin/commit/
> 3aa75a49ff71a38dcb128d5165d417afc4758568

If that's the fix then this bug is a duplicate of bug 1298284, right?

However, I don't fully see the relationship here:

> He indicated that that first error was where that PV first appeared and once
> it was removed, all the pods were impacted.

Can you please elaborate a bit more on that?
Comment 5 Josep 'Pep' Turro Mauri 2016-03-08 10:42:46 EST
(In reply to hchen from comment #4)
> This is an indication that the PV is deleted by kubelet. This behavior is
> fixed in k8s PR 19600.

Ok, thanks!

Then I'm closing this one as a duplicate of bug 1313391 (the enterprise version of bug 1298284 which track the inclusion of that k8s PR in openshift).

*** This bug has been marked as a duplicate of bug 1313391 ***

Note You need to log in before you can comment on or make changes to this bug.