Bug 1314961 - dnf-automatic crashes when 'None' emitter is used
dnf-automatic crashes when 'None' emitter is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: EasyFix, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-05 01:35 EST by John Obaterspok
Modified: 2016-10-04 14:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 14:03:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Obaterspok 2016-03-05 01:35:44 EST
Description of problem:

Use below setting in /etc/dnf/automatic causes it to crash since if the emitter specified wasn't motd, stdio, email it will "assert False" in "/usr/lib/python3.4/site-packages/dnf/automatic/main.py", line 61
   [emitters]
   # If emit_via is None or left blank, no messages will be sent.
   emit_via = None

#/usr/bin/dnf-automatic /etc/dnf/automatic.conf --timer
Traceback (most recent call last):
  File "/usr/bin/dnf-automatic", line 32, in <module>
    sys.exit(dnf.automatic.main.main(sys.argv[1:]))
  File "/usr/lib/python3.4/site-packages/dnf/automatic/main.py", line 154, in main
    emitters = build_emitters(conf)
  File "/usr/lib/python3.4/site-packages/dnf/automatic/main.py", line 61, in build_emitters
    assert False

Changing the emitter to email allows the command to succeed.

Version-Release number of selected component (if applicable):
dnf-automatic-1.1.6-2.fc23.noarch
Comment 1 Fedora Admin XMLRPC Client 2016-07-08 05:35:13 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Štěpán Smetana 2016-08-05 04:47:52 EDT
PR was created: https://github.com/rpm-software-management/dnf/pull/556
Option left blank like "emitter = " should work too, but it worked like that before.

Note You need to log in before you can comment on or make changes to this bug.