Bug 1314964 - [gnome-session] user-defined X resources not used in GNOME on Wayland session
[gnome-session] user-defined X resources not used in GNOME on Wayland session
Status: CLOSED DUPLICATE of bug 1149905
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-05 03:00 EST by Joachim Frieben
Modified: 2017-01-18 14:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-18 14:04:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-03-05 03:00:50 EST
Description of problem:
X environment variables like XENVIRONMENT and XUSERFILESEARCHPATH defined in $HOME/.login are ignored in a GNOME on Wayland session. Accordingly, any user-defined X resources are ignored when X applications are launched from the application grid.

Version-Release number of selected component (if applicable):
gdm-3.19.90-1.fc24

How reproducible:
Always.

Steps to Reproduce:
1. Start GNOME on Wayland session.
2. Launch X application from the application grid.

Actual results:
X application ignores user-specific X resources.

Expected results:
X application applies user-specific X resources.

Additional info:
- X environment variables are set correctly in a GNOME on Xorg session.
- This issue also applies to current Fedora 23.
Comment 1 Joachim Frieben 2016-03-07 03:54:39 EST
As a matter of fact, using the C shell, all environment variables set in $HOME/.login or $HOME/.cshrc are being ignored, not only the X related ones.
Comment 2 Joachim Frieben 2017-01-18 14:04:37 EST

*** This bug has been marked as a duplicate of bug 1149905 ***

Note You need to log in before you can comment on or make changes to this bug.