Bug 1315025 - Packaging conflict between python-qt5 and python3-qt5
Packaging conflict between python-qt5 and python3-qt5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-qt5 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-05 17:04 EST by stan
Modified: 2016-03-07 14:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 09:09:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stan 2016-03-05 17:04:45 EST
Description of problem:
When upgrading python-qt5, I get a file conflict error from dnf.

Version-Release number of selected component (if applicable):
python-qt5-5.5.1-13.fc25.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.  Have python3-qt5 installed.
2.  Try to upgrade python-qt5
3.

Actual results:
file /usr/lib/rpm/macros.d/macros.pyqt5 from install of python-qt5-5.5.1-13.fc25.x86_64 conflicts with file from package python3-qt5-5.5.1-11.fc25.x86_64


Expected results:
Successful upgrade

Additional info:
---> Package python-qt5.x86_64 5.5.1-11.fc25 will be upgraded
---> Package python-qt5.x86_64 5.5.1-13.fc25 will be an upgrade
Comment 1 Rex Dieter 2016-03-07 09:09:06 EST
you have to upgrade both python-qt5 and python3-qt5 at the same time.
Comment 2 stan 2016-03-07 14:01:15 EST
Yeah, I was going to post information about that this morning after I noticed that the python3 packages aren't updating because of dependency errors.  Not sure what those errors are, though.

Here is the output from dnf.

Upgrading:                                                                                                                                                                                                                             python-qt5                                                     x86_64                                              5.5.1-14.fc25                                                  rawhide                                              3.9 M 

Skipping packages with broken dependencies:                                                                                                                                                                                                   
 python3-qt5                                                    x86_64                                              5.5.1-14.fc25                                                  rawhide                                              3.9 M
 python3-qt5-devel                                              x86_64                                              5.5.1-14.fc25                                                  rawhide                                              502 k


And if I accept this, then it gives me the error I reported.
Comment 3 Rex Dieter 2016-03-07 14:05:14 EST
What does this say:

dnf update --best 

??
Comment 4 Rex Dieter 2016-03-07 14:08:31 EST
and, if you happen to have an oddly named python3-webkit pkg installed, try removing it.
Comment 5 stan 2016-03-07 14:13:14 EST
Thanks for that command.  That's really useful.

Here are the relevant entries from the output:

package python3-webengine-5.5.1-11.fc25.x86_64 requires python3-qt5(x86-64) = 5.5.1-11.fc25, but none of the providers can be installed.

package python3-webkit-5.5.1-11.fc25.x86_64 requires python3-qt5(x86-64) = 5.5.1-11.fc25, but none of the providers can be installed.

So, you're saying I should remove these?  They're obsolete?   Or do they just need their dependencies updated to the latest python3-qt5 version?
Comment 6 Rex Dieter 2016-03-07 14:24:41 EST
Yes, remove those
Comment 7 Rex Dieter 2016-03-07 14:28:26 EST
%changelog
* Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
- add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
Comment 8 stan 2016-03-07 14:30:02 EST
That did the trick!

Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.