Bug 1315043 - [RFE] As a user I want to see ostree information published in a content view
[RFE] As a user I want to see ostree information published in a content view
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: 6.2
Assigned To: Partha Aji
Sachin Ghai
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
: 1317767 (view as bug list)
Depends On:
Blocks: 1321771
  Show dependency treegraph
 
Reported: 2016-03-06 01:09 EST by Partha Aji
Modified: 2016-07-27 05:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release introduces the ability to provision Red Hat Atomic Host in addition to standard Red Hat Enterprise Linux. This includes syncing down Atomic Content, promoting that content through a lifecycle environment, and provisioning Atomic Hosts.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:25:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
content tab is empty, ideally it should show the ostree branches (52.31 KB, image/png)
2016-03-28 08:29 EDT, Sachin Ghai
no flags Details
published cv shows ostree branches count along with other contents (66.26 KB, image/png)
2016-03-31 08:22 EDT, Sachin Ghai
no flags Details
I can see ostree branches version, name, commit etc under CV-> version- ostree branches (66.40 KB, image/png)
2016-03-31 09:39 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13719 None None None 2016-04-22 12:06 EDT

  None (edit)
Description Partha Aji 2016-03-06 01:09:44 EST

    
Comment 1 Partha Aji 2016-03-06 01:09:46 EST
Created from redmine issue http://projects.theforeman.org/issues/13719
Comment 2 Partha Aji 2016-03-06 01:09:49 EST
Upstream bug assigned to paji@redhat.com
Comment 3 Partha Aji 2016-03-06 01:20:22 EST
This is an important function, to list ostree repositories belonging to a content view version.
Comment 4 Bryan Kearney 2016-03-14 18:12:19 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13719 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|244b900df7028f3b03e7c0490977b5864b344123.
Comment 5 Partha Aji 2016-03-14 22:57:12 EDT
Changes in the UI for this -> https://partha.fedorapeople.org/ostree-prs/PR-5874/
Comment 6 Partha Aji 2016-03-17 21:45:16 EDT
*** Bug 1317767 has been marked as a duplicate of this bug. ***
Comment 7 Sachin Ghai 2016-03-28 08:28:27 EDT
Verified with sat6.2 beta snap5.1

I don't see ostree contents published in a content-view from webUI. Please see the attached screenshot.
Comment 8 Sachin Ghai 2016-03-28 08:29 EDT
Created attachment 1140850 [details]
content tab is empty, ideally it should show the ostree branches
Comment 9 Partha Aji 2016-03-29 14:25:39 EDT
Sachin,

Can ya verify this one too as a part of -> https://bugzilla.redhat.com/show_bug.cgi?id=1318549 

This should show up correctly on your satellite once you restart httpd/foreman-tasks
Comment 10 Sachin Ghai 2016-03-30 02:03:48 EDT
Yeah..I can see ostree info correctly with suggested workaround.

I'll retest this bz along with bz1318549 once fix is available with snap. Thanks
Comment 11 Sachin Ghai 2016-03-31 08:21:15 EDT
Verified with sat6.2 beta snap6.

I can see ostree info in a specific version:

[root@cloud-qe-15 ~]# hammer -u admin -p changeme content-view version info --organization-id 1  --content-view-id 3 --id 5
ID:                     5
Name:                   custom_ostree 3.0
Version:                3.0
Description:            
Content View ID:        3
Content View Name:      custom_ostree
Content View Label:     custom_ostree
Lifecycle Environments: 
 1) ID:    1
    Name:  Library
    Label: Library
Repositories:           
 1) ID:    26
    Name:  rhel7_ostree
    Label: rhel7_ostree
 2) ID:    27
    Name:  f23_ostree
    Label: f23_ostree
 3) ID:    28
    Name:  busybox
    Label: busybox
 4) ID:    25
    Name:  sat6tool7
    Label: sat6tool7
Puppet Modules:         
 1) ID:      1
    Name:    motd
    Author:  jeffmccune
    Version: 1.0.3

[root@cloud-qe-15 ~]#
Comment 12 Sachin Ghai 2016-03-31 08:21:51 EDT
Content-view info shows ostree repo:


[root@cloud-qe-15 ~]# hammer -u admin -p changeme content-view info --organization-id 1 --id 3
ID:                     3
Name:                   custom_ostree
Label:                  custom_ostree
Composite:              false
Description:            
Content Host Count:     0
Organization:           Default Organization
Yum Repositories:       
 1) ID:    2
    Name:  sat6tool7
    Label: sat6tool7
Docker Repositories:    
 1) ID:    24
    Name:  busybox
    Label: busybox
OSTree Repositories:    
 1) ID:    7
    Name:  rhel7_ostree
    Label: rhel7_ostree
 2) ID:    8
    Name:  f23_ostree
    Label: f23_ostree
Puppet Modules:         
 1) ID:      1
    Name:    motd
    Author:  jeffmccune
    Created: 2016/03/31 09:45:33
    Updated: 2016/03/31 09:45:33
Lifecycle Environments: 
 1) ID:   2
    Name: Dev
 2) ID:   1
    Name: Library
Versions:               
 1) ID:        3
    Version:   1.0
    Published: 2016/03/31 09:35:36
 2) ID:        4
    Version:   2.0
    Published: 2016/03/31 09:41:37
 3) ID:        5
    Version:   3.0
    Published: 2016/03/31 09:45:43
Components:             

Activation Keys:

[root@cloud-qe-15 ~]#
Comment 13 Sachin Ghai 2016-03-31 08:22 EDT
Created attachment 1142199 [details]
published cv shows ostree branches count along with other contents
Comment 15 Sachin Ghai 2016-03-31 09:39 EDT
Created attachment 1142230 [details]
I can see ostree branches version, name, commit etc under CV-> version- ostree branches
Comment 17 Sachin Ghai 2016-04-01 07:38:32 EDT
Moving this to verified as per comments 12, 13, 15
Comment 19 errata-xmlrpc 2016-07-27 05:25:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.