Bug 1315051 - Can't build metapackage on Fedora 24
Can't build metapackage on Fedora 24
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 03:34 EST by Remi Collet
Modified: 2016-03-26 14:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: scl-utils-2.0.1-10.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:15:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-fix-grep-usage-in-macros.scl-1315051.patch (1.63 KB, patch)
2016-03-07 03:53 EST, Remi Collet
no flags Details | Diff

  None (edit)
Description Remi Collet 2016-03-06 03:34:37 EST
During the build

    Mauvaise longueur de la locale : « /builddir/build/BUILDROOT/php70-1.0-3.fc24.remi.x86_64/iso_639.tab » dans %lang(/builddir/build/BUILDROOT/php70-1.0-3.fc24.remi.x86_64/iso_639.tab)
    Mauvaise longueur de la locale : « /builddir/build/BUILDROOT/php70-1.0-3.fc24.remi.x86_64/iso_639.tab » dans %lang(/builddir/build/BUILDROOT/php70

Mauvaise longueur de la locale => Bad locale length

Adding glibc-all-langpacks in the buildroot doesn't help.
Comment 1 Remi Collet 2016-03-07 03:53 EST
Created attachment 1133685 [details]
0001-fix-grep-usage-in-macros.scl-1315051.patch

grep fails because iso_639.tab is considered as binary.

Using --text option solves this issue.

Null diff between metapackage (runtime) packages built on F23 and F24.
Comment 2 Fedora Update System 2016-03-09 11:04:31 EST
scl-utils-2.0.1-10.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff75f9caf4
Comment 3 Fedora Update System 2016-03-09 20:55:15 EST
scl-utils-2.0.1-10.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff75f9caf4
Comment 4 Fedora Update System 2016-03-26 14:15:06 EDT
scl-utils-2.0.1-10.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.