Bug 1315057 - restsharp: FTBFS in rawhide
restsharp: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: restsharp (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://github.com/restsharp/RestShar...
:
Depends On:
Blocks: openra
  Show dependency treegraph
 
Reported: 2016-03-06 05:40 EST by Raphael Groner
Modified: 2016-03-08 08:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 08:58:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2016-03-06 05:40:45 EST
Description of problem:
Package restsharp fails to build from source in rawhide. The log shows an internal error of CSC (mono component).

Version-Release number of selected component (if applicable):
restsharp 105.2.3-4.fc24
mono*     4.3.2-7.fc25

Steps to Reproduce:
koji build --scratch f25 restsharp-105.2.3-4.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/restsharp


Interesting snippet from build.log (both i686 and x86_64):
…
CSC:  warning CS2029: Invalid conditional define symbol `'
CSC:  warning CS2029: Invalid conditional define symbol `'
CSC:  warning CS1691: `1658' is not a valid warning number
CSC: error CS1904: `1658' is not a valid warning number
	Task "Csc" execution -- FAILED
	Done building target "CoreCompile" in project "/builddir/build/BUILD/RestSharp-105.2.3/RestSharp.Net45/RestSharp.Net45.Signed.csproj".-- FAILED
Done building project "/builddir/build/BUILD/RestSharp-105.2.3/RestSharp.Net45/RestSharp.Net45.Signed.csproj".-- FAILED
Build FAILED.
Warnings:
/builddir/build/BUILD/RestSharp-105.2.3/RestSharp.Net45/RestSharp.Net45.Signed.csproj (default targets) ->
/usr/lib/mono/4.5/Microsoft.CSharp.targets (CoreCompile target) ->
	CSC:  warning CS2029: Invalid conditional define symbol `'
	CSC:  warning CS2029: Invalid conditional define symbol `'
	CSC:  warning CS1691: `1658' is not a valid warning number
Errors:
/builddir/build/BUILD/RestSharp-105.2.3/RestSharp.Net45/RestSharp.Net45.Signed.csproj (default targets) ->
/usr/lib/mono/4.5/Microsoft.CSharp.targets (CoreCompile target) ->
	CSC: error CS1904: `1658' is not a valid warning number
	 3 Warning(s)
	 1 Error(s)
Comment 1 Timotheus Pokorra 2016-03-07 03:01:36 EST
Comparing with previous builds of RestSharp, this error used to be a warning:

CSC:  warning CS2029: Invalid conditional define symbol `'
CSC:  warning CS2029: Invalid conditional define symbol `'
CSC:  warning CS1691: `1658' is not a valid warning number

So I guess, with Mono 4.3.2 this has now become an error.

I find/grepped for 1658, and found it was in some csproj files in a NoWarn tag.
So that invalid warning number can be removed there.

This works for me locally, when I add these lines to the %prep section in restsharp.spec:

sed -i 's#,1658</NoWarn>#</NoWarn>#g' RestSharp.Net45/RestSharp.Net45.Signed.csproj
sed -i 's#,1658</NoWarn>#</NoWarn>#g' RestSharp.Net45/RestSharp.Net45.Signed.csproj
sed -i 's#,1658</NoWarn>#</NoWarn>#g' RestSharp/RestSharp.Net35.csproj
Comment 2 Raphael Groner 2016-03-08 08:58:51 EST
Thanks for the workaround. Reported to upstream.

Note You need to log in before you can comment on or make changes to this bug.