This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1315060 - spacecmd package-search doesn't return results when ran from command line, same works from spacecmd shell
spacecmd package-search doesn't return results when ran from command line, sa...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
570
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Kašpárek
Jan Hutař
:
Depends On:
Blocks: sat570-triage
  Show dependency treegraph
 
Reported: 2016-03-06 06:10 EST by Ilan Green
Modified: 2016-09-06 02:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: spacecmd-2.3.0-5-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 08:24:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2190791 None None None 2016-03-06 08:51 EST

  None (edit)
Description Ilan Green 2016-03-06 06:10:03 EST
Description of problem:
spacecmd package search doesn't return results when ran from a shell script

Version-Release number of selected component (if applicable):
spacecmd-2.3.0-4.el6sat.noarch

How reproducible:
make a shell script
#!/bin/bash
# script to search for packages within red hat satellite
#
/usr/bin/spacecmd -- package_search $1

Steps to Reproduce:
1. create script
2. run "<script>  <package name or partial name>" # Select a package which is available
3.

Actual results:
no results

Expected results:
List of packages matching the search criteria

Additional info:
Per the below link it seems a fix is available in upstream and it is all about changing one line in the spacecmd
https://github.com/spacewalkproject/spacewalk/commit/ffd53a926df0ef997eb40d2dd4eae656208a777e
Comment 1 Tomas Lestach 2016-03-07 03:57:51 EST
Moving to MODIFIED, since the fix is available in upstream.
Comment 19 errata-xmlrpc 2016-08-22 08:24:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1645.html

Note You need to log in before you can comment on or make changes to this bug.