Bug 1315101 - foreman-debug incorrectly gives exit code of 1 (non-zero when it should have been zero)
foreman-debug incorrectly gives exit code of 1 (non-zero when it should have ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Foreman Debug (Show other bugs)
6.1.7
x86_64 Linux
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Lukas Zapletal
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 12:25 EST by Reartes Guillermo
Modified: 2016-07-27 05:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:04:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13442 None None None 2016-04-22 12:11 EDT

  None (edit)
Description Reartes Guillermo 2016-03-06 12:25:53 EST
Description of problem:

i am executing foreman-debug from a ruby program and i noticed that formeman-debug is givin an exit code of 1, but there was no (known to me) error.

i executed formeman-debug directly from the shell and it also gives an exit code of 1 instead of 0.


Version-Release number of selected component (if applicable):
Satellite 6.1.7


How reproducible:
always


Steps to Reproduce:
1. execute 'foreman-debug'
2. check exit code (echo $?)


Actual results:
# foreman-debug 
Exporting tasks, this may take a few minutes.
Copying entire file: /tmp/task-export-1457284097.tar.gz


 HOSTNAME: testsat7.example.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.2 (Maipo)
  FOREMAN: 1.7.2
SATELLITE: 6.1.7
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.6.2
  DENIALS: 25


A debug file has been created: /tmp/foreman-debug-bNhs9.tar.xz (1148640 bytes)

[root@testsat7 ~]# echo $?
1

Expected results:
# echo $?
0

Additional info:

http://projects.theforeman.org/issues/13442
foreman-debug script should return a meaningful exit code
Comment 1 Lukas Zapletal 2016-03-07 04:23:45 EST
Hello,

this patch has been included in 6.2 already.
Comment 2 Lukas Zapletal 2016-03-07 04:43:41 EST
TRIAGE NOTES: This is already in our 6.2 builds.
Comment 5 Kedar Bidarkar 2016-04-07 02:57:01 EDT
[foreman-installer]# foreman-debug 
Processing... (takes a while)Exporting tasks, this may take a few minutes.


 HOSTNAME: abc.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.2 (Maipo)
  FOREMAN: 1.11.0.9
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.6.2
  DENIALS: 21


A debug file has been created: /tmp/foreman-debug-Qf6yT.tar.xz (955348 bytes)

To upload a tarball to our secure site, please use the -u option.
[root@katello1 foreman-installer]# echo $?
0


VERIFIED with sat62-snap6
Comment 7 errata-xmlrpc 2016-07-27 05:04:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.