Bug 1315117 - Can't connect to Samba share, "failed to retrieve share list from server"
Can't connect to Samba share, "failed to retrieve share list from server"
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rashid Khan
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-03-06 18:52 EST by Chris Murphy
Modified: 2017-08-08 11:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-08-08 09:06:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
journal (207.29 KB, text/plain)
2016-03-06 18:52 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2016-03-06 18:52:48 EST
Created attachment 1133568 [details]

Description of problem: Fedora 23 Server running samba, Fedora 23 workstation can mount the share without problem. Fedora 24 in a Boxes VM can't.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Nautilus window
2. click Other Locations
3. double click Windows Network

Actual results:

Unable to access location
Failed to retrieve share list from server: No such file or directory

Expected results:

Should work.

Additional info:

[  889.322697] localhost gvfsd[1522]: ** (gvfsd:1522): WARNING **: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Failed to retrieve share list from server: No such file or directory
Comment 1 Chris Murphy 2016-03-07 00:35:22 EST
Standby. This is probably bug 1313085.
Comment 2 Chris Murphy 2016-05-30 15:41:27 EDT
The problem does not happen on baremetal. 

It does happen on gnome-boxes-3.20.2-2.fc24.x86_64 with Fedora-Workstation-Live-x86_64-24-20160528.n.0.iso but I don't know why or how to get more information on the cause. I do have internet in the guest, and I can ssh from within the guest to the server running samba that I'm trying to connect to.

May 30 15:34:03 localhost gvfsd[1607]: ** (gvfsd:1607): WARNING **: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Failed to retrieve share list from server: Connection refused
May 30 15:34:03 localhost gvfsd[1607]: ** (process:2383): WARNING **: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: The specified location is not mounted
May 30 15:34:07 localhost gvfsd[1607]: ** (gvfsd:1607): WARNING **: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Failed to retrieve share list from server: No such file or directory
Comment 3 Chris Murphy 2016-05-30 15:48:29 EDT
Looks like the problem is NAT. If I change the guest VM virtual network interface from NAT to macvtap in virt-manager, the problem doesn't happen. Maybe it's expected behavior?
Comment 4 Ondrej Holy 2016-05-31 06:07:28 EDT
Thanks frothe bug report. Yes, I suppose that the problem may be caused by the NAT and I don't think this is relevant to GVfs. Does smbclient cmd works for you? 

smbclient -L //SERVER/ -d 99 2> smbclient.log

Please provide the smbclient.log if it doesn't work.
Comment 5 Chris Murphy 2016-08-15 13:36:11 EDT
Does work with Fedora 24 and Fedora 25, tested in qemu-kvm using 
Comment 6 Ondrej Holy 2016-08-23 06:22:11 EDT
Ah, I've supposed that this doesn't work. So gvfs-mount smb://[SERVER]/ should work correctly in that case also. Nautilus tries to mount smb://[YOUR DEFAULT WORKGROUP]/, so maybe there is some problem with name resolution. Maybe you can also try smbclient -L //[WORKGROUP]/, but I am not sure that smbclient can be used this way...
Comment 7 Matthew 2016-11-30 10:43:55 EST
I have the same problem in fedora24, it appeared after upgrading from Fedora23.

It seems the firewall is blocking access to some ports required to allow samba to get the shares from a server.
If I turn off the firewall, my shares become available again.
So what was changed between Fedora23 and Fedora 24 regarding how the firewall works?

I have read a few posts on the internet and on Fedora / Redhat discussion sites, that the general consensus is that the firewall is the problem, however I have yet to see anyone state a real fix for it, apart from turning off the firewall, or for some mapping direct to a share rather than browsing to it.

There also seems to be confusion as to which ports should be accessible for Samba to browse the network.

Is there anymore information on Samba ports required for browsing the network?
Comment 8 Wayne Sheridan Winch, Jr. 2017-02-14 15:38:30 EST
Same problem here in F25.  I was able to get it working by opening up the samba-client service destination port in the firewall as well as UDP source ports 137-139 (NetBIOS-related services).  This implies there's some UDP communication originating from Windows hosts from those service ports to random ports on your Fedora box, hence the requirement for those source port specifications.

As always, YMMV.  Hope this helps.
Comment 9 Ondrej Holy 2017-02-15 01:39:45 EST
Thanks for your feedback. Sounds like firewalld issue then, changing component...
Comment 10 Fedora End Of Life 2017-07-25 16:17:57 EDT
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2017-08-08 09:06:17 EDT
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 12 Matthew 2017-08-08 11:47:45 EDT
This Bug was still present in F25, I have had the same bug ever since I upgrade from 23 to 24, then 24 to 25..

However on 12 July 2017, after a further update on F25 and before I upgraded to F26, I located a possible reason for this Bug, or at least managed to fix it.

Originally I was unable to get any of the Firewall zones in Fedora 24 and 25 to allow me to browse the network, same error as given. Not even Fedora Workstation zone  worked for me, but on 12 July 2017, I went through all the settings for all the zones setup by default when firewall is installed and located a difference which I hadn't noticed before.
I run my system with Firewall set to default to the "Home" Zone. This used to let me browse the network when I was using Fedora 23, then it stopped when I upgraded to F24.  I had tried using Fedora Workstation zone, but that had never worked and I saw no actual difference to the ports in either the Fedora Workstation Zone or my home zone.

However now under the firewall Zone "Fedora Workstation" the firewall rules showed there were two ports I hadn't noticed before  1025-65535 tcp and 1025-65535 udp.  these ports were missing from my Home Zone.

So I changed my default Zone in the firewall to "Fedora Workstation", this didn't help, but I then noticed you have to also set the Zone of "Connections" in a separate area so they also use the zone of "Fedora Workstation".  That is in my case Connections enpls6 (enpls6) and Virbr0 (virbr0) had to be set to use the zone "Fedora Worksation".
Once that was set, I could browse the network again.

The solution then was to make sure my Home Zone also had the two extra ports added.

I'm not sure how long these two ports were present, but originally they were never present even for the Fedora Workstation zone.

Note You need to log in before you can comment on or make changes to this bug.