Bug 1315140 - Statedump crashes in open-behind because of NULL dereference
Statedump crashes in open-behind because of NULL dereference
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: open-behind (Show other bugs)
3.7.9
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
: ZStream
Depends On: 1277924 1294051
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 22:12 EST by Pranith Kumar K
Modified: 2016-04-19 03:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294051
Environment:
Last Closed: 2016-04-19 03:21:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-06 22:19:54 EST
REVIEW: http://review.gluster.org/13615 (performance/open-behind: Fix fdctx dump NULL dereference) posted (#1) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-07 03:31:56 EST
COMMIT: http://review.gluster.org/13615 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6fbaa124e33e6604621826c54eac987dfe590d27
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Thu Dec 24 14:29:33 2015 +0530

    performance/open-behind: Fix fdctx dump NULL dereference
    
    Also printing flags correctly in statedump now
    
     >Change-Id: Ibfdd74aab5643ecc47d0a88f109d5d1050685f5a
     >BUG: 1294051
     >Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
     >Reviewed-on: http://review.gluster.org/13076
     >Smoke: Gluster Build System <jenkins@build.gluster.com>
     >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
     >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
     >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    BUG: 1315140
    Change-Id: Ib11306831b930cddaa2c6e293be5d00dff41e880
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13615
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2016-04-19 03:21:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.