Bug 1315154 - [RFE] celery flower support for qpid broker
[RFE] celery flower support for qpid broker
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.7
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-07 00:37 EST by Pradeep Kumar Surisetty
Modified: 2017-07-26 15:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-11 15:01:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kumar Surisetty 2016-03-07 00:37:38 EST
Description of problem:

Flower is a web based tool for monitoring and administrating Celery clusters

Its a nice tool to have for  celery monitoring. It provides nice dashboard with celery tasks details like ( scheduled, queued, task times, failed tasks, ..etc) 

But It doesn't support qpid broker. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. configure flower for your pulp server

celery -A pulp.server.async.app flower --port=5555

2. open http://satserver:5555/broker
3.

Actual results:

Its not supported 


Expected results:

provide support for qpid

Additional info:
Comment 1 Brian Bouterse 2016-03-30 13:08:18 EDT
I've tried doing this myself and also found that there is not support for the Qpid broker. The worker discovery, tasks being run, utilization, and all of that works, but seeing anything about the broker state does not work.

I commented upstream about the lack of Qpid support[0]. The recommendation from mher (who I talk with on #celery) was to implement a broker class for flower [1].

[0]: https://github.com/mher/flower/issues/473#issuecomment-157513954
[1]: https://github.com/mher/flower/issues/473#issuecomment-172391854
Comment 2 Bryan Kearney 2016-07-26 15:02:17 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Brian Bouterse 2016-08-08 12:22:18 EDT
Actually we already had an issue on this upstream. I'm linking up the bugs now. Thanks @bbuckingham
Comment 6 pulp-infra@redhat.com 2016-11-21 13:57:21 EST
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.
Comment 7 pulp-infra@redhat.com 2016-11-21 13:57:23 EST
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.
Comment 8 Michael Hrivnak 2017-01-11 15:01:10 EST
We are going to track this upstream only, particularly since it is not part of the product. Thanks for suggesting it.

https://pulp.plan.io/issues/857

Note You need to log in before you can comment on or make changes to this bug.